[SOLVED] Black screen error on Ludei splash screen

  • Hello C2 fellas! ^^

    Does anyone knows what means the error "not found getElementById: c2canvasdiv" in the Cocoon Launcher?

    I'm trying to compile my game in the Ludei/Cocoon and the game execution don't goes beyond Ludei splash screen.

    Thanks for advance for the attention and collaboration.

    [EDIT]

    The problem wasn't the c2canvasdiv in the HTML and JavaScript, but the WEBGL! When I turned it off, the game worked well in the Ludei compile.

  • This is the block of HTML that it is looking for.

    Make sure that it exists in your index.html file, or you will get that error.

    <div id="c2canvasdiv">
    
    <!-- The canvas the project will render to.  If you change its ID, don't forget to change the ID the runtime looks for in the jQuery events above (ready() and cr_sizeCanvas()). --> 
    
    <canvas id="c2canvas" width="1024" height="768">
    
    <!-- This text is displayed if the visitor's browser does not support HTML5. You can change it, but it is a good idea to link to a description of a browser	and provide some links to download some popular HTML5-compatible browsers. --> 
    
    </canvas>
    
    </div>
    [/code:ew4yhi3p]
  • Thanks for the help, gumshoe2029!

    Actually this piece of code doesn't exist in my index.html, but I changed here and the error continued to be shown in the Cocoon Launcher.

    I did right?

    <html>

    <body>

    <script src="c2runtime.js">

    </script>

    <div id="c2canvasdiv">

    <canvas id="c2canvas" width="864" height="486">

    </canvas>

    </div>

    </body>

    </html>

  • gumshoe2029 I tested my mini-games separately in the Cocoon Launcher and ALL functioned normally, but the most curious was that all exhibited the SAME MESSAGE ERROR ("not found getElementById: c2canvasdiv")!

    So the c2canvas isn't the problem that is preventing the execution of my project on the phone.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • gumshoe2029 Problem solved! It was the WebGL.

    The game worked perfectly when I turned it off. I know I leave it on is recommended for good performance of the game, but unfortunately learned that this seems to be the only solution.

  • Glad you got it fixed. It looks like only iOS8 supports webGL (on the Apple side).

    http://mobilehtml5.org/

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)