Socket.io Server in delphi??

  • Hi there folks i am having this annoying problem with the socket.io plugin.

    I am a delphi programmer and i am trying to set up a server with it.

    So the delphi server works and it is able to recieve data through tcp with socket.io in construct but the send action of the plugin doesnt work.

    When i connect to the server i get this :

    GET /socket.io/1/?t=1368459064951 HTTP/1.1

    Host: localhost:1050

    Connection: keep-alive

    User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.64 Safari/537.31

    Origin: localhost

    Accept: */*

    Referer: localhost

    Accept-Encoding: gzip,deflate,sdch

    Accept-Language: en-GB,en-US;q=0.8,en;q=0.6

    Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.3

    So i know it is possible for construct to send data to TCP server, but when i use the send action nothing appears.

    Does anybody know why???

    Thanks for your time.

  • Hi, have you been able to read message on a Delphi client from another server with standard Socket.io?

    If so, could you tell me how?

    Thank you

  • Hi, have you been able to read message on a Delphi client from another server with standard Socket.io?

    If so, could you tell me how?

    Thank you

    This is a 4 year old thread and the OP hasn't been on here for over 3 years (check his profile).

    Unfortunately, it's doubtful he will respond.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Tanks

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)