How do I set my tiles to ground level?

  • Hello guys!

    I'm completely new in Construct 2.

    And I have very silly question.

    I'm trying to do 1st level of Super Mario. I'm using tileset from original game. It looks almost as I need but I always have my "ground" in the middle of the screen. Not at bottom. When I'm trying to put this tiles down, I have the same result. They are moving to the center of my screen. I think there's something very simple solution of my problem.

    I want It to look like this:

    But i have this:

    What I'm doing wrong?

  • You probably have scrollto behaviour on Mario and this is the result of that..

  • In the layout view, hold the control button and scroll the mouse wheel down to zoom the view out. You should see a dotted outline, which represents the camera view. Your tiles might be in the middle of that.

  • Oh, Yes! LittleStain, you are right!

    Indeed, when I've disabled ScrollTo problem has gone.

    But I need ScrollTo behavior to scroll my level to the right. What must I do to have scroll left-right and have my ground at bottom?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Easiest way would be to put the bottom of your tilemap on the bottom of the layout (the white area) and if you have unbounded scrolling turn it off (but I don't think you have)

    Scrollto won't scroll beyond layout..

  • Thank you very much! It really works!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)