How do I make save load work?

  • I've read and tried the tutorials on saving. I tested the save, load with the ghost shooter tutorial and it worked BUT when i uploaded it to Kongregate it no longer saved. Now with a new game i am working on I can't get save to work even with Run testing. I used the keyboard on S clicked save to myfile. keyboard on L clicked load myfile. I am wondering if i need to do more than this to get the saves to work and if so what? My new game is a clicker/idle type game with buttons so not sure if that causes me to not be able to save with the keyboard controls.

    Also is it possible to get system every x seconds to save game to myfile. I'd tried that coding but doesn't work either. i'd prefer this type of save if anyone can explain or point me toward an explanation a beginner would understand. thanks

  • Upload an example capx where save and load doesn't work, i will fix it for you.

  • hope this works

  • hope this works

    Okay, i can't see any problem, everythings save and load.

    Better make buttons on screen for saving and loading, if you had problems with keyboard actions.

  • Oh, and if you want to save the game state without buttons, better not use every tick, use every second, or add a save action to all conditions that changing the game state.

  • thanks for taking a look. i can't figure out why it's not saving for me. I'll try making buttons and see if that works

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • In this case, where all you actually want to save are the variables, why not use webstorage?

  • If i knew how I would probably do that. I've searched on and off for 2 days before posting this and didnt really find any tutorial that "showed" exactly what i needed to do.

  • update: I changed nothing and now the save/load with keyboard is working for me. IDK what was going on

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)