how do I run a project which requires rex.rainbows function?

  • I want to open an older project which used rex.rainbows excellent function plugin. I understand scirra have added something like this with the same name, and that rex has created a new version called function2

    But I still cant open my project. there seems to already be a pugin in the standard install dir of construct2. I tried installing function2, but this didnt help.

    Any ideas? I don't want to overwrite the official function plugin, as I dont want to have this problem forever...

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I could not find a copy of rexes original rex_function anywhere online, so went through some year old backups of my long dead laptop and found a copy of it - phew! If anyone has the same issue, pm me and Ill send you it. It seems to work along side the official function, as its called "func" not function.

    So the next issue is how do I migrate my hundreds of rex_functions to the official function plugin or rex_functoin2? i assume I have to more or less re-write them all from scratch? Or is it possible for me to hack source files in notepad?

    the only reason I want to do this is so that in another year from now, if I cant find the original rex_funciton, I am able to open the project still and not lose several man months of work.

  • How were you able to install the rex plug ins? When I tried I got this error...

    Download rex_timeline start...

    Traceback (most recent call last):

    File "wx\_core.pyc", line 14669, in <lambda>

    File "model\Repository.pyc", line 43, in myfinishCB

    File "model\Repository.pyc", line 112, in _unzip

    File "share\MyZipFile.pyc", line 8, in UnZipFile

    File "zipfile.pyc", line 962, in extractall

    File "zipfile.pyc", line 950, in extract

    File "zipfile.pyc", line 986, in _extract_member

    File "os.pyc", line 157, in makedirs

    WindowsError: [Error 5] Access is denied: u'C:\\Program Files\\Construct 2\\exporters\\html5\\plugins\\rex_timeline'

  • Try to install with administrator and you will not get error adennis123

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)