run layout question/run game

0 favourites
  • 4 posts
From the Asset Store
Game "Word Search" with complete Source-Code (Construct 3 / .c3p) + HTML5 Exported.
  • I'm completely new to this. Just downloaded the free version and ran over the start of the beginners guide. I'm stuck at page 3. I have not made it very far. I've done everything as the tutorial has instructed so far, even restarted and did over again. My problem is after clicking on "Run" in the top left corner, and after the trying "Run Layout" in the "home" tab it just brings me to a web screen showing my character. I can not move at all. I even tried the "debug layout", it shows the same thing but does show keyboard entries registering, but still no movement.

    Now, Is this an old guide for an older version of construct? I know this would happen to me alot when trying to use Valve's Hammer Editor. I would find many old guides for older versions of the tool and somethings have changed with out updated tutorials or am I just an idiot missing something?

    For the record I did look around for an answer, I couldn't find it.

    And like I said, I followed the guide to the t.

    Any suggestions, or is this because I'm using the free version?

    EDIT: Sorry, should have explained a bit more. I'm at the point in the beginners guide where after you give your character behaviors (and add keyboard & mouse) the guide suggest you run it. I'm supposed to be able to move around and what not at this point so the guide tells me.

  • Shouldn't have anything to do with the free version or the guide being old..

    Has the character got a movement behaviour?

    In the properties of the movement behaviour is default control set to yes?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • One thing, I did not follow the guide to the t as I said. I forgot about the beginning. I chose the standard layout option (1st one on list). The guide says to re size the image to 1280x1024 and that it should fit but it did not. I had to re size the image to 1708x960 to fill all the white space as the tutorial pic showed, I'm confused about the dashed lines. Is that where everything is supposed to go that would be functional? If so, what is the rest of the space for? In the second screen shot I made the back round invisible so you can see what I mean.

    Sorry if the pics don't upload right. I'm a gamer, not a poster on the internet guy. I can build you a pc but I can't figure out how to use a smart phone to save the life of me if you get my gist. So posting pics online isn't familiar to me. Or using

    or . I've been spoiled by drag and drop. I'll fix it if they don't show up.

    Edit, apparently I can't post pics yet. ok.

    Yes, to both questions, guy has behaviors, 8 way movement, scroll to, and bound to layer. The default controls are set to "yes".

    In the pic I tried to post it shows a large rectangular box then a smaller dashed line box within the larger box. When scaling the back round texture I had it fill the entire white box and ignored the dashed box inside as the tutorial did not say anything about that. Or I missed it. Maybe that is the issue?

    Also, as the tutorial says to place the bullet and explosion outside of the layer. I have those in the grey section outside of both boxes. I'm wondering if the playable area is the dashed box and anything out side of that but within the larger white box is what they meant by outside the layer? (layer being the dashed box).

    It's been a long day, sorry if I seem to be rambling, I'm so sick of reading and editing. Hope I'm clear.

  • ROFL. I am an idiot it turns out. It works just fine, just not with your normal W,A,S,D movement, have to use the arrow keys like this is 1991 game!

    Thank you for your attention anyways. I was really starting to think I was just stupid, guess I sort of was.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)