How do I run exported node version on Ubuntu?

0 favourites
  • 6 posts
From the Asset Store
Full game Construct 2 and Construct 3 to post on Google Play
  • Hi, I exported my game to produce a linux64 dir.

    I have ubuntu 12.04.

    The question is, how do I run the game on Linux?

    1) Do I need to install node.js?

    2) Do I need to install any other node packages?

    3) If I do need to install node, how then do I run the game?

    4) Anyone know how to get the equivalent of a start menu on Unbuntu desktop, such that I can find where I can run an xterm? There seems to be no way to run apps unless they have been installed via the "Ubuntu software center", which doesnt even have node. i guess I could try and navigate using the file browser to wherever xterm is installed, but it seems a backward step.

    Any help greatly appreciated.

  • I don't use linux at all, but the node webkit Export (I think this is the one you make allusion) should be enough.(maybe run the "nw" file in the game folder exported, not sure)

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • ok, figured it out, you have to get an xterm running (very hidden in ubuntu), then cd to the dir when you put the linux64 export, then do a chmod 777 on the file which doesnt have an extension, then you can run it by doing:

    $ ./nameoffilewithoutanextension

  • On Ubuntu, you just need to right-click the file, select Properties, and enable execute permission. You don't need anything else installed.

  • Sorry to bump, I've been trying to run my game on Ubuntu 13.10 and nothing happens when I try to run the file, even if I set it to enable excute permission. I'm not an avid Linux user so I don't know what could be wrong... however the computer I'm using uses a onboard geforce card, maybe that's the problem? The game doesn't even show up though, I click it and nothing happens...

    Has anyone tried their games on Ubuntu 13.10?

  • andreyin, I'm having the same issue, can't open my game on 13.10

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)