Remove all(most) bounce/spring in physics

  • Hi,

    I have objects (70 at most) using physics dropping into the scene. I want them to drop and act more like 10ton bricks but currently when one lands on top of a stack it makes them all spring/bounce.

    I have set Object's and platform's Elasticity to 0, and all other parameters to 1. I have tried increasing their density with no luck and also tried increase the World Gravity with no luck either. All the objects still "Compress" and "Bounce" when another lands on it.

    Attached an example .cap : dl.dropbox.com/u/2175584/example%20still%20springy.capx

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • On start of layout:

    Select any of your physics object~

    Under Physics: Global settings~

    Select set stepping iterations~

    Tweak the position iterations into higher value~

    It will make more consumption of performance~

    But more accurate physics calculation~

  • Thank you, I have set it to 12 (default is 3). Is that consider too many iteration?

    I have a another issue now I am noticing that when 6 or more drop they raise/swish for 1-2 pixels and then raise up. Can you stop this?

  • When I see your question~

    I immediately thinking of a settings from another engine~

    Called "Min Penetration For Penalty"~

    But my apologize, I can't help you on this~

    Since C2 doesn't have this setting yet~

    Even though set velocity & position iterations to 1000~

    Also cause a little bit pixels offset. But I think it's fine~

    Player won't see it unless they look very very closely~

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)