"Tiled" background not appearing in game properly

  • Hi,

    I have a bunch of square images "tiles" that represent roads (straight up/down, left/right, corners, etc).

    To quickly mockup a tiny neighborhood I put together a 10x10 grid of these tiles... and in the editor all looks perfect.

    When I preview it in my browser... on load there is a bunch of flickering as some (~25%) of the tiles change between various shapes until stopping on a completely incorrect tile.

    I'm lost as to why this happens... I have no behaviors on these tiles, I simply dragged them in to the editor from my filesystem and arranged them as needed.

    Additional notes in case relevant: my "grid" is larger than my viewport (1024x600) and my "car" is set to have a car and scrollto behavior.

  • Doh! I solved it!

    When I was dragging in images from exploring into Construct 2 I first tried to drag in several at once... this didn't appear to work and I only got 1 sprite... BUT! it created an animation sequence for that tile with the remaining images I thought that didn't come in.

    Erasing them from the animation sequence for that sprite solved it.

    PS - IMHO, dragging in 2 or more images should create "N" objects... not 1 object with "N" animation frames. Am I alone on this?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Yes you are I think, as this was modified in the past after a request from the community.

    People were thinking that creating multiple objects is just a bad idea and that you should use only a limited number of object types for a great number of instances. Hence import drag/dropped multiple frames to a single animation and not several new objects.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)