How do I make the preview work in browser

  • nothing works for me..

    I would like to use C2 for my projects, but still not working when i launch on the browser..

    can't find localhost:50000 adress on any browser.

    I'm on win 7 home premium.

    I wonder if someone who had this issue for a long time found where it can come from ?

    I read the whole topics on bug reports, and nothing could help much.

    PS: I precise i tryed with tutorials projects. So it should be clean

  • when I press the preview button, either my browser gets opened automatically, or a new tab is opened in my browser..

    what browser are you using for preview?

    Is the browser installed on your PC?

  • Have you been through the suggestions in the Troubleshooting Construct 2's preview server as previously mentioned by Ashley?

  • LittleStain : I'm using firefox but also tryed with IE and Chrome. it opens the tab. But can't find local host adress.

    Zenox : Yes i tryed most of it (I'll check all this once again.)

    I also wondr why it wont open in the browser selected in the paameters but always in my "default" one my comp (firefox here)

  • Found this on the interwebs.

    Not sure if this is relevant to your situation, though..

    http://www.moorlandit.net/index.php/200 ... dows-7-96/

  • Type localhost - it should be a blank white screen.

    Check your hosts file.

    Note: Windows 7 won't let you edit the hosts file. You have to save a copy somewhere, edit it, then copy and paste it over the hosts file.

    And ensure your firewall allows port 50000

  • Hosts file checking and many other checks are mentioned in the tutorial, so maybe he's already checked this.

  • i think troubles comes from the host file. I'll try your method DUTOIT. Thanks a lot for your quick responses !

    I come back to you to tell if that worked

  • ho finally it works in chrome... don't get it but wont work in Firefox ? is that normal ?

    i just changed the port to 60000 instead

    Anyway, really happy i can use C2 now

  • Is your firefox trying to force https ? How to disable it? I don't know, it might be a plugin or something. Couple people having issue that firefox is forcing viewing over ssl

    Glad its working on chrome.

    Good to change to port.

    zenox98, yeah, but with win 7 you edit the hosts file thinking it is all good and it doesn't save it hence you got to copy it somewhere else, edit it, and copy it back.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Is your firefox trying to force https ? How to disable it? I don't know, it might be a plugin or something. Couple people having issue that firefox is forcing viewing over ssl

    yes firefox forces https .

  • [quote:3q0dovwk]yes firefox forces https .

    I can't help... haven't looked into that myself. I just know it has created a number issues for others.

    Mine defaults to standard http and I got latest, but very very few plugins now.

    That is why I think it is a plugin or something.

    You could bypass it, I think.... no, cancel that, that will open a security risk. Best search google or see what the others have to say.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)