Posting to the web and SSL...

0 favourites
  • 5 posts
From the Asset Store
$12 USD
Incorporate WebMIDI into your Construct 3 projects
  • I recently posted an app to my bluehost website. I then discovered that bluehost offers a free (shared) SSL certificate so I went ahead and got that working. This is actually kind of important because my app uses voice recognition, and without SSL it asks for permission every. time. you. click. the. talk. button.

    I can now get to my app using an "https://" link OR the old "http://" link.

    Here's the problem: I made a small update and uploaded it. When I use the new link the app doesn't detect that there is a new version. It's just using the cached one. (Even after repeated page reloads, after restarting the browser, etc.) The old "http://" link picked up the change immediately and downloaded the new version.

    Why is only one link working? They are both pointing to the same files, right? Confused.

  • Strangely, when I tried to load my website at work today I was only seeing the OLD version of the site. I tried to force the site to update but that didn't help. Switching to Chrome's Incognito Mode fixed the problem, so I completely cleared my cache and now everything seems to be working as intended.

    So I'm thinking it was an issue with my website cache not updating? (I have a loading page in my app that is supposed to check for that. Not sure why it stopped working.)

    Bottom line: everything is back to normal, for now.

  • This is a browser issue, not a C2 or server issue. This is why I test with the browser caching disabled (when possible). You can temporarily disable the browser cache using most developer tools (like Developer Tools for Chrome or Firebug for FF) or you can do it manually in the browser options.

  • gumshoe2029 I need to run some more tests but my problem seems to have returned. Here's what I find unusual:

    I upload a new Project File to my website, along with a new offline.appcache file. Then this:


    I go to: and my app correctly identifies that there is an update and downloads it.


    I go to the secure version of my site: and the app doesn't get the update. (Even after I reload the page over and over again.)

    Also, I think each of these links uses a different Local Storage file, right? Could that be related to the issue?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Your secure version worked fine for me:

    But I have never visited your site, so I had no cached version available.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)