Please help!

  • In the middle of creating an entry for Ludum Dare, everything was going well. Then without warning I get this message (linked below) informing me of a failure to open the project. I had changed nothing since being able to open it perfectly previously. I've tried restarting everything. Can anyone please advise me if there is a way to salvage my work?!

    imgur.com/cchFI1y

  • rename your capx as .zip

    unzip it

    look for the missing texture and compare with any reference in the .caproj (open it with a text editor)

    the .caproj is an xml file which reference all plugins, behavior, objecttypes, and project parameters of your project.

    It is read on opening and if you read the error message it just means that you have a ressource missing.

    You can either delete the reference in the xml (if you know xml well enough) or recreate a placeholder png you would put on the texture folder and try opening the caproj with construct2

  • Do you still have the backup file for you capx? It should be named something like this; "game.capx.backup1". Just remove the ".backup1" part and see if that backup works.

  • The tips given by Yann and retrodude are great.

    However, there is a reason why you need to start learning to use backups and source control, and it's never too late to start.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Many thanks! Yann and retrodue - your tips worked great. I restored it from the backup file in the end. Excal - I've learned a valuable lesson!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)