Z order problem....?

  • Hi!

    I am using Construct 2 beta release, r120.2 (free version).

    I am having trouble with this particular issue in my project. When I click on the instruction button to display the instruction window, other elements appear as well. I have checked the event sheet, and this is not supposed to happen.

    I have also checked the Z order to ensure that the instruction window is always at the top of the layer.

    I tried making the unneeded elements invisible when I click on the instruction button and display the instruction window, but when I close the instruction window, the animation that was playing seems to be missing an element.

    How do I check for any errors or bugs in my project?

    Thank you.

  • Debugging is a skill. Most bugs occur with variables not behaving as you might think they are. The best way to manually debug those is to create a text object called 'Debug' and have it show output for whatever variable you are trying to test or debug for.

    As for your specific problem, do you have a capx you can share?

  • Hi!

    I have posted a .capx file at this link. box.com/s/7eo2p59qg2ux3t5fdxud

    Thank you for helping :)

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Hi!

    Can you elaborate on the part where you mentioned, " create a text object called 'Debug' and have it show output for whatever variable you are trying to test or debug for".

    Thank you so much :)

  • Yes, for example, the latest build of my space game can be found here: http://exeneva.com/html5/SpaceGameV2

    You'll notice I have updating information, most noticeably the FPS in the upper right hand corner. You can't see it, but I have in invisible text box on the left called Debug. I use this whenever I am testing a variable.

    Can you share your file as single .capx instead of a zip?

  • Hi!

    Here is the single .capx file: box.com/s/2m61pa74sr9yy0hd5cl7

    Thank you :)

  • What other elements are appearing for you? I only see the instructions window when I click on it.

  • Hi!

    Which version of Construct 2 are you using?

    These are the elements that are appearing and are not supposed to be there when I clicked on the Instructions button.

    • SpoonWaterAnimation
    • FlourWaterAnimation
    • SpoonAlcoholAnimation
    • The whole iodine bottle and its layers.
  • It's not the C2 version. That should have nothing to do with the output.

    I'm rendering on Firefox and only seeing the Instruction window when I click the instructions button.

  • Hi!

    I rendered and previewed it on Chrome and IE, and the same problem still persists. Will try install Firefox and check if the same problems appear again.

  • By any chance, did you try testing it on other browsers?

    Thank you.

  • I only tested it on FF. The problem doesn't seem like it's browser-specific.

    Can you post a screenshot of what you're seeing?

  • Hi!

    I tried rendering it on Firefox. The same problem still persists?

    Which C2 version are you using? Because I'm using the Construct 2 beta release R120.2 (free version). Not sure if this information helps much.

  • Hi!

    What is FF?

    By the way, these are the screenshots at these links:

    box.com/s/z51gs4bvucby5f1liipe

    box.com/s/dxccv2hhb60eqid2k161

    box.com/s/4svqe6rtt9aj5cjm3dcp

    box.com/s/45mstrb3n0xgyerbcfnv

  • This is what I see. Looks fine to me.

    <img src="http://i.imgur.com/lXRZJZn.png" border="0" />

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)