How do I Open a Capx.Autosave File?

  • I have a new issue now . Last night I stopped working on the test.capx file from before and started my work from the swordthrow.capx file. However when i downloaded it from Firefox I opened it with construct 2 but I did not save it to my computer. I got a ton of work done and I saved a lot, but this morning when i went to open the file it was nowhere to be found. The only traces I could find of it was the .capx.autosave file in my temp folder. When I try to open that I get a message that says "Error Document Empty. The file maybe invalid. Try checking the file in a text editor (Projects are saved in XML format).", but the file isn't empty and I don't wish to redo multiple hours worth of work. Also, it does not seem that Scirra will allow me to post files with the .autosave extension. What is the point of an autosave function if you can't open the files? If anyone has any experience with this sort of problem, please share it with me. I would really appreciate it.

  • Make a copy of the autosave file and rename it to remove the word "autosave" so it should say WHATEVERYOURFILENAME.capx and it will open.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • The name of the file is swordThrow.capx, but the file type is autosave. Renaming it doesn't seem to help

  • So it says swordThrow.capx.autosave right It is a .capx you have to remove the autosave extension and then direct C2 to the file. I know cause the same thing has happen to me numerous times. When you remove the autosave extension the icon will change to Construct 2 project folder icon.

    Depending on you windows setting it would pop up asking if you want to change the extension. Say yes.

  • I'm not sure how to do that since it already says just .capx

  • Go to your folder that has the autosave and show me a snapshot. Depending on how you OS is setup it is not showing you the .autosave extension which you have to switch on for it to work.

    EDIT::

    This is how it look when you change an autosave file

    [attachment=0:5k0w6avj][/attachment:5k0w6avj]

  • /

  • Yes you folder isn't setup to show extensions. As you see in my post above. You would have to go to the folder options and uncheck hide extensions so that you can see its actual full name. Also you can do the same for the backup also. Make a copy and change the extension. remove the backup part.

  • I think that you're right, under the file details i can see that it's name is SwordThrow.capx.autosave, I'm just not sure how to change it.

    Sorry, I posted before I saw your new post. Is this option under folder properties? I can't find it

  • If you click to rename it does it show you the full name with the autosave?? If so just remove it..Or make sure nothing is selected click on the 'Organize' button to the left and click "Folder and Search Options" On the View tab find "Hide extensions of known file types' and uncheck hit okay and you should be able to see it. Make a copy of the file right click->Rename->remove '.autosave'

  • It worked!! You are awesome, Thank You!

  • You welcome. I have no clue what it is that make C2 do that but it has gotten me quite a few times.

  • Haha me either, I'm just glad that it's fixed

  • Just rename the file to .capx

  • Problem solved, thanks though

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)