make an opbject invisible in editor?

0 favourites
  • 6 posts
From the Asset Store
Supports 1D, 2D, 3D arrays. Import and export arrays in JSON format
  • Is it me, or is the "make invisible in editor" option gone from 103? Without it you cant see, or directly edit, objects under other objects - you can highlight them with the "object list" thing on the right, but when you right click on a single instance to edit animations etc in the layout window, you get the top most object. Obvoisly we can move the top objects out of the way, or send objects to the back, but to make groups invisible was handy.

    We avoid the use of layers as far as possible, as when you add or remove a layer, you have to go through all the event sheets editing by hand anything which referenced a layer number as they all change. A great enhancement for a future version would be for the actions to access layers by name or internal ID, not by the order number which changes all the time.

  • You can access layers by name.

    For example: System: Set layer "game" scale to 1.0

  • I cant find this option. In the System actions, there is only "Set layer Scale", which takes a number only. It pops up the "objects with expressions" dialogue, which is a bit odd as you cant do much with other objects here - only enter a layer number. Or perhaps a good way is to attach a dummy sprite object on each layer, and call them "layer1" etc, then in the Layer parameter, do something like Layer1.LayerNumber? Actually I think this might be the way forward.

    It would be really nice to have layers in the "objects with expressions" dialogue.

  • Instead of entering a number you enter the name within quotes, like "game" in Shinkans example.

  • Ah, ic! But this is not validated, and it doesn't change when you change the layer name. However, is better than layer number, so ill start using it.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Yeah since you can put any expression in the field it's not really "parseable".

    For instance I often do a:

    -> go to layout "Level_"&str(int(replace(layouName,"Level_",""))+1)

    to go to my next level when I name them "Level_1","Level_2","Level_3" etc.

    I don't think c2 should/could parse this thing :D

    (Yeah I wish there were a "go to next layout" I could use more meaning full titles for my levels \o/)

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)