Node-Webkit Exporting without Frame/Toolbar...Issue

  • Hi everyone,

    for some reason no matter what i do when I export is always doing it without the Window frame,

    anyone have any idea why this is happening? so basically i am stuck with a borderless executable game.

    I tried the following;

    1] editing the the html export options

    2] re install consrtuct2

    and it didn't work, btw this is the steam version of construct.

    any help would be greatly apreciated.

    thnx

  • going to try to perform a complete cleanup and see if that will fix it, and then if that doesn't work i will just try it on a new windows profile.

  • found a work around for this but not happy :0[

  • goofyerr Mind sharing the workaround?

  • sure TwinTails,

    I found some forum articles in here on making your own custom borders and enabling dragging the mouse on it, below is the closest example, i can't find the others but you get the idea.

    goo.gl/VfFBf2

    I think the new node-webkit exported for C2 might have a bug, because i also tried editing a file within the exported targeted OS and it didn't work, i can provide all my research on here if you like.

    to test this bug on your machine, go to the folder where you are running the game, and look for a file that has the following extension .nw, open it using 7zip, winzip, winrar and look for package.json file and edit the "window" : section to apply what you are interested in testing, for me was the frame save it and run the game, see what you get.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Make sure you have the "window frame" option checked on export.

    Sorry if this is too obvious - if you've done this already then it sounds like a bug with the export settings.

  • its ok, thank you very much Colludium, but i did try that :0p

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)