Need help please. loading to my website

0 favourites
  • 5 posts
From the Asset Store
Game with complete Source-Code (Construct 3 / .c3p) + HTML5 Exported.
  • I have been searching the forum and tutorials for a solution

    and having a bit of difficulty.

    Please help.

    I have tried this game on my public dropbox and it works fine.


    when I try to load to my website I am getting a black screen,

    I have checked the browser for errors.

    It loads the game files but I am getting some error messages

    and don't know what they mean....

    please help

    In Chrome I used:

    Google Chrome: Press Ctrl + Shift + J to open Developer Tools. There should be an error log at the bottom of the pane that opens

    The error messages are:

    Uncaught TypeError: Cannot read property 'b' of undefined

    Failed to load resource

    The key "minimal-ui" is not recognized and ignored. ( for Apple only so I don't think it matters with Chrome)

    Anyway, can someone with more experience look at this

    for me please.

    The website is ..

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • : Can you send me the game files via zip and I'll try uploading somewhere else.. Did you fully upload all the files to your website?

  • I have it on my dropbox..

    so there is an issue somehow with the server maybe...??

    and yes all the files are loaded.

  • The first thing I would check is the whether the folder and file names on the server are spelled EXACTLY the same as what the exported code is asking for. Web servers are usually Linux machines, and spelling is case sensitive, so if you have a folder "Images" but the code is looking for "images" then it wont find what it is looking for!

  • I am doing some 'rule outs' to rule out

    the obvious things..


    since this is my first C2 to be published on this server (yahoo web server)

    I tried to upload a simple sample game in C2

    and it works.

    see it here if you like ..

    so its NOT a C2 issue.

    it doesn't like something in my 'coding'..

    In Chrome I press CTRL-SHIFT-J

    and this appears..

    the error message is

    Uncaught TypeError: Cannot read property 'b' of undefined

    it says:


    so line 659 of the c2runtime file ... something in there it doesn't like.. Cannot read property 'b' of undefined

    here is line 659, I don't see undefined

    !1,[[0,[0,256]],[0,[0,192]]]],[-1,t.prototype.b.D,null,0x668df35c15e2b,!1,[[11,"ItemBgColor"],[7,[0,5]]]],[22,v.prototype.b.Xa,null,0xcad4ba639d9d9,!1,[[2,["bb",!1]]]],[22,v.prototype.b.Xa,null,0x6fa32999853d1,!1,[[2,["nb",!1]]]],[22,v.prototype.b.Xa,null,627241421676204,!1,[[2,["pb",!1]]]],[22,v.prototype.b.Xa,null,8625734537192015,!1,[[2,["break_2",!1]]]],[22,v.prototype.b.Xa,null,0x7d8103a94b331,!1,[[2,["blue_2",!1]]]],[22,v.prototype.b.Xa,null,5032684564340195,!1,[[2,["brown_2",!1]]]]]],[0,null, anybody see anything unusual ? hhhmmmmmm anybody happen to know what 'b' they are talking about?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)