Multiplayer Plugin interupted connection

  • Hi,

    I've been playing around with the multiplayer plugin a bit lately, specifically working with using it AND the Synaptop plugin in the same game. For testing purposes, I wrote a game based off the platformer example, which I first networked using the Synaptop plugin, then added the Multiplayer plugin to sync a couple of the other objects (such as moving platforms). I managed to do this, and it works (objects sync etc), except for the following:

    The LogText box just shows 0's instead of "Connected, logging in..." etc.

    in Firebug the console gives me the message:

    The connection to wss://multiplayer.scirra.com/ was interrupted while the page was loading.

    this.sigws = new WebSocket(url_, SIGNALLING_WEBSOCKET_PROTOCOL);

    when I exit the game.

    and the firebug console gives me the message:

    TypeError: this.library is undefined

    this.library.unsubscribed(this, users_id, pclosed);

    when a non-host user exits the game.

    What confuses me most is if it didn't connect to wss://multiplayer.scirra.com, how did it sync the objects that it did?

  • It's probably caused by the other plugin. Can you reproduce this using only the official Multiplayer plugin?

  • Well right now when I try to test, even with the official multiplayer plugin unedited, I'm getting "Signalling error: room full". I'm guessing this means too many people are testing the multiplayer example right now?

    Note: It did give these messages in the log when a peer disconnected and I disconnected respectively.

    However when I changed the name of the game to: "scirra-gametutorial3.1" I get around the signalling error, and the game works like it should in every respect, but I still got those messages.

    Edit: I however did test the game as an iframe or as a page, and it wasn't bringing up these messages when I ran it as it's own page, only when I was running it as an iframe.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Father testing suggests that the "this.library.unsubscribed" message is not associated with the Multiplayer plugin in any way, however the other message "The connection to wss://multiplayer.scirra.com/ was interrupted while the page was loading. this.sigws = new WebSocket(url_, SIGNALLING_WEBSOCKET_PROTOCOL);" is connected to the multiplayer plugin.

    Edit: I've also solved the problem where the network text was just displaying 0's. The main problem remains.

  • Would it help if I use my own server or a Synaptop-supported server when running the games on Synaptop?

    How would I create/implement a signalling server that does the same thing as wss://multiplayer.scirra.com/?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)