<SOLVED> Issues with picking in binding system

0 favourites
  • 9 posts
From the Asset Store
Create complex dialogues with ease with this tool/template!
  • I made a system for input in my actual project, but I think I still have some misunderstandings with families because it isn't working as intended, and seems risky to leave it as it is.

    Binded controls for several players (only 2p set atm) are stored on an array, then there are a lot of "on keycode pressed" that call the corresponding function when said buttons are pressed. That function simply sets the corresponding instance of a family to true/false.

    The booleans are being set correctly, but the "is X input boolean" events doesn't seem to be doing what they should. That is, when lots of keys for different players are pressed at the same time, sometimes one does not do anything at all. I thought it would be fixed adding a "for each <familyName>", but nope! If you look closely, when pressing Up arrow (player 2) and W (player 1) at the same time, only one of those spawn three particles.

    I would greatly appreciate any help. If you see that I did something stupid like placing an useless loop, or a way simpler way to achieve this system, I would love to hear it!

    If you don't understand something in the .capx, please reply and I will explain it further. I just want to end this family nightmare!

    Capx (click on keys and press another to bind it): https://www.dropbox.com/sh/a397h7mbwj3k ... gTDra?dl=0

  • I think you may be hitting hardware limits here. Most keyboards are only designed to accept the buttons being pressed simultaneously under a certain limit.

    A cheap keyboard may only allow 3 at once, where a gaming keyboard may allow 8 or 10... if you have multiple people using the same keyboard (local multiplayer) then that could be affecting your problem here.


  • I don't think so though, I've played lots of local multiplayer games on this machine and they worked perfectly! Still, the second issue made me suspect that this problem wasn't the hardwares' fault.

  • Getting a 404 error when trying to download your capx


  • Reuploaded

  • You have plugins installed that I don't use

    Can you remove the plugin or does it affect what your issue is? It usually best to provide a plugin-free capx for troubleshooting or a minimal recreation of the issue if removing plugins isn't really possible.


  • Sorry! Litetween is quite a common plugin though... (reuploaded)

  • Nevermind! fixed it. Had an "else" that wasn't affected by the "for each". Can't figure out how to edit the post title to <solved>, so I'll probably delete it later overall. Thanks, SoldjahBoy though!

    Edit: You apparently cannot delete topics either?

    Edit2: Figured out how to edit topic titles

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Glad you fixed it.

    Yes LiteTween is a common plugin, but that doesn't mean everyone uses it or wants it installed into their C2. I already have a lot of plugins, and I don't like having to add more that I will never use

    All sorted though anyway!


Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)