Layout don't trigs 'On start of Layout', after loading a saved game successfully.

  • [ SOLVED ]

    I have an issue with (I suspect) the save state.

    The game saves the state at the changing of every layout. All works fine, I can load and save the game multiple times without any problem.

    If the game window (or tab) is closed and then open again, I have the option to load the game in the main menu. Loading the game everything works fine, but when I change the layout to the one that supposed to bring me to the Save/Load functions, it loads the layout but it stops, basically it should trig the 'On start of layout', but nothing happens.

    The associated event sheet has a 'On start of layout' without additional conditions and it doesn't trig. I checked even with logs, but nothing happen. The debug shows 0% activities on the active Event Sheets and Layout, variables seems all good, but the game doesn't progress. Am I missing something silly simple?

    I repeat, I can go through that layout multiple times with no issue starting a new game. The problem occurs after restarting the app, loading the game, playing the level and only after moving to that layout. The issue occurs both with HTML 5 export and NW.js

    Any idea?

    Thank you.

    Tagged:

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I am not sure I fully understood your question. But if you are saving the game immediately before switching to another layout, saving may finish in another layout.

    So I suggest saving the game, wait for "On save complete" event, and only then go to another layout.

  • Thank you dop2000

    It seems I might have solved the issue. Basically when loading the file I was disabling the Save group to avoid it to save automatically. When I wrote the code time ago I might have assumed that reloading the layout after coming back from another, that would reset the group enable/disable settings.

    Thanks for the help!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)