My layer isn't going invisible when I tell it to?

  • I've been trying to fix this since last night and it's driving me a little crazy. I'm brand new to Construct2; This is the first game I've tried to make.

    I have an event that says:

    • On keyboard Esc pressed && Layer 5 is visible

         - Set layer 5 invisible.

         - Set layer 6 visible.

         

    I have also tried it with:

    • Set layer 6 visible.
    • Set TextItem1 invisible
    • Set TextItem2 invisible.

    The result is that it will set layer 6 as visible, but will not set layer 5 as invisible. In the second way, it will set TextItem1 invisible, set layer 6 as invisible, but TextItem2 is still visible.

    Anyone have any idea where I'm going wrong here?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Hello Narilka can you post a capx file for us to take a look at. Usually these are issues with the order of events. If you post a sample .capx file, then someone may be able to take a look and find the issue much faster for you.

    Also, welcome to the community, can't wait to see what you create!

    I HIGHLY recommend spending time reading the manual (you also get badges and reputation points for doing so), and also doing many tutorials.

    Many items that seem to not work when starting with construct come from not being familiar with how the engine works.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)