How do I use Intel XDK to show ads?

  • Hi all.

    I'm having a little trouble trying to setup AdMob. When I try to preview/test my game to see if the ads show up, nothing shows up at all. Here's the steps I've done so far

    1. I've signed up and signed into the AdMob website.

    2. I added Admob to my project

    3. Then, I added my Banner ID into the AdMob properties.

    4. I added a piece of code that says, "On start of layout" --> "Show banner ad at position bottom center...."

    5. Then I exported from Construct2 with Cordova for Android.

    6. Then, I opened Intel XDK, and started a new project. In the process I set 'use cordova plugins' and 'game project' to 'no'.

    7. In 'project info' I upgrade to cordova.

    8. Then I filled in 'build setting' the app ID and app name

    9. Then, I added the extra Admob plugin.

    In the end I try to run the emulator but the following error occured.

    I really hope someone can help me..

  • up..

  • Did you solve this already? Got the same issue.

  • He Kopa, found this on a Intel xdk page.

    "Because an AdMob application includes a third-party Cordova plugin, it will only run on a real device. You must use the Build tab to create an APK (for Android) or IPA (for iOS) to test your AdMob application. If you attempt to run this app using the Emulate, Test or Debug tabs the AdMob APIs will fail. Apps that utilize Cordova plugins can only be built using the Cordova build targets. Attempting to use the "legacy" build targets will not work."

    Gonna try to build it tonight and see what happens. Ill let you know what my findings are.

  • Ok so I managed to build it finally. But it's still not showing anything.

  • export your project inside intel XDK with "CROSSWALK ANDROID", not with "ANDROID" and then inside the zip file you have your two apk, upload the ARM version to your device.

  • I did, still no succes. Do I need to upload it to google as a alpha testing build before it'll work?

    Gonna run through this tutorial, seems to be the most recent:

    https://www.scirra.com/tutorials/4848/h ... alk/page-6

  • Remember to modify the adMob plugin property "Test Mode" to "No" in Construct 2 in your final (production) version before uploading it to Google Play Console.

    Those steps may be subjects to change if ever, since the writing of this article, adMob, XDK or even Google Play have been updated and their interface modified.

    i think you need to upload to google play to see the ads

  • Jippie, finally got this to work. Indeed uploading it to Google's Play Store and publishing it as an Alpha does the job! Thanks for the support imthep85 and others!

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • what is an alpha?? i have the same problem, i am a super newbie ....

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)