Intel XDK build failed [SOLVED]

0 favourites
  • 11 posts
From the Asset Store
Create your own beautiful snowman in this fun game!
  • Hi,

    I want to export my new game to Android Crosswalk with the Intel XDK. The build fails everytime. I tried all different Crosswalk versions and I don't think it has something to do with that.

    These are my build settings and the Error Message that I receive:

    The build failed.

    An error occurred while building the application. Verify your build assets are correct and try again.

    You can view the log of the Android build here

    Build Log:

    The App ID is "com.stonewashedpc.PhysXCapitalism"

    The App Name is "PhysXCapitalism"

    Crosswalk Version:

    Plugin installed: SplashScreen (org.apache.cordova.splashscreen)

    Plugin installed: Device (org.apache.cordova.device)

    Plugin installed: org.apache.cordova.inappbrowser (org.apache.cordova.inappbrowser)

    App name updated to [PhysXCapitalism]

    Updated "minSdkVersion" with "14"

    Updated "targetSdkVersion" with "19"

    Updated "installLocation" to "auto"

    Updated "screenOrientation" to "landscape"

    Updated "versionCode" to "60001"

    Updated "versionName" to "0.0.1"

    Added "debuggable" to "false"

    In the build log I found this line:


    /Developer/android-sdk-linux/tools/ant/build.xml:932: The following error occurred while executing this line:

    /Developer/android-sdk-linux/tools/ant/build.xml:950: null returned: 1

    Also I found out that the problem could have something to do with the inappbrowser plugin.

    I hope someone can help.


  • Can anyone help?

    (I also found a line in my build log where it says something about an invalid filename "men??background.png". I don't know this filename.)


  • Try to build it with Crosswalk 7 and/or check if any of your pictures/files contain special characters.

  • /Developer/android-sdk-linux/tools/ant/build.xml:950: null returned: 1 <---- you have updated your C2/intelXDK ?are u using free C2 license? is your C2 a beta version?

    seems more likely a linux intelxdk problem

    also possible the C2 being beta most plugins don't work well on beta versions!

    about this problem :>invalid filename "men??background.png".

    check your assets maybe you have a big project, and you forgot 1 png to drop it in the screen, and you have events for it!

  • Thanks for your reply!

    I have the personal license of c2 and I updated the Intel XDK yesterday. But I don't know if I have the beta. How can I check that? I will see if there are other problems that you described.

  • I tried to recreate my whole project now so there shouldn't be any file that has events but is not in the project (also I had an background.png but I deleted it). I have c2 version 200 64bit for windows. My Intel XDK is version 1995. I also tried to put in a .png file in my images folder with the name that is in the build log error and I tried to delete the part of my project with the browser plugin to see if the plugin doesn't work. But I have still the same problem.

    Any other ideas?


  • I found out that the problem could have something to do with invalid letters in the file name of my png file. That could be a linux problem. But i can't fix the error by renaming it because i don't even know the file.


  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Ok I changed the name of my MenüBackground.png file and now it works!

    It seems that the ü is an invalid character and the Intel XDK changed the ü to an ?? so it was men??background.png .

    but now I have a problem with a blackscreen when I start my app and my smartphone shows a message that the app doesn't answer. i will create a new thread for that.

    Thanks for everyone's help!

  • for the app if doesn't answer its because of the build you made in intelxdk it might not be compatible with ur device, try from intexdk not to export for cordova or other things, but the normal Android that says nothing else near it, and test it that way. also might be because you have to many audio files and your scene is preloading all. and instead of preloading when the app loading bar appears loads it when you should already play at freezes the game, happened to me a few times. its a bit tricky its a matter of building the right apk for that issue!

    well for see if you have beta you go in the capx you made, unzip it since capx works like a zip and you'l get a project with a caproj file in it, open the caproj with notepad, and you will see version in the top lines, around 7-10 line. if its 205.2 then its beta, the stable release its 200 so the version should say Version : 200.000 or 200.001 smth if it says 205.200 then its the beta version the other way to check it is going into C2 and check the info button will tell you about the current version

  • Thanks for your help.

    I will try to use the other android exports. But my last app did work with crosswalk and cordova.

  • Hi,

    I'm having problem while building the app for IOS. I uploaded the distribution certificate and downloaded the provisioning files but still facing the problem with the build.

    An error occurred while building the application. Verify your build assets are correct and try again.

    Build Log:

    Building a Cordova 5.1.1 application.

    The application name is "-----------"

    The package name is " -----------------"

    This is what I'm getting while build.

    Please help.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)