How do I implement AdMob ads

0 favourites
  • 13 posts
From the Asset Store
StartApp Ads
$11.99 USD
[ C2 ] [ C3 ] support C3 build service | You can use Banner Ads, Interstitial Ads and Video Reward Ads.
  • Hi,

    Up to now, AdMobs ads fail to appear in my Google Play (exported with Intel XDK) game. The problem is very simple : nothing appears.

    I added the C2 AdMob plugin.

    I created an account on

    I entered the ID for banner ads and interstitial ads, both are in the following style : ca-app-pub-0123456789012345/0123456789 (is this the correct ID that should be entered? I entered th whole thing with the "/")

    I didn't add the publisher ID anywhere because C2 isn't asking for it as far as I know

    I put overlap to "yes" and test to "true"

    I added the Admob plugin in the third party plugins in XDK as referenced in the manual :

    My code is as follow :

    At start of layout : preload banner ad

    On banner ad received : Show banner ad at position bottom-center size Smart-banner

    I did all this and still nothing appears in the game (which is still in beta test on google play)

    Any idea what I'm doing wrong?


  • Hey, I just saw this other topic - it looks like there was a bit of discussion on here.. maybe it would be helpful to you:

  • Try using a different Condition to show your banner.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Thanks, I'll try that. But what will happen if there is no ad preloaded? Will the banner be displayed without any ads?

    I'll add a 2 second delay before the banner appears, or is it another way?

    After a second thought I don't think this is the problem, because in another game mode, I have

    on start on layout : preload banner ad

    (at the end of level) : show banner ad (along with other events that ARE performed, in the same event)

    ...and the banner ad is not displayed either.

    mudmask : yup, I read this one before posting, but it didn't help. In my case, I think everything should work, and it doesn't, so I tried to describe what I did as clearly as possible to see if someone can spot an error.

  • My app is now released in one territory and the ads still aren't working (using Intel XDK)...

    I followed every step on this link :

    And nothing appear on screen (even not an empty banner... nothing at all)

    Is there any step that should be made and isn't included in the manual?

    Anyone else is having problem with Admob integration?

  • Rable Ya I'm also having A LOT of trouble getting AdMob to work so you aren't alone. I'll be following this thread because I belive we have the same problem.

  • I just ran a bunch of tests in order to make the ads work in my main project. One thing that I found is that you need to export to a new folder and import it in XDK. If you re-export in an existing folder, it will not work, I guess.

    EDIT : For some reason, it also appear that the test ads are not displayed when I use the IDs I created for my game. However, if I select the IDs I created for my test project, it works.

  • I just ran a bunch of tests in order to make the ads work in my main project. One thing that I found is that you need to export to a new folder and import it in XDK. If you re-export in an existing folder, it will not work, I guess.


    That should not affect anything to do with ads showing. Admob gets confusing because, depending on what version of C2 youre using, Admob is implemented differently - its all about the plugin. What URL are you using for the adMob plugin in XDK??

    These instructions are the best Ive found and do work: ... creen-ads/

    BTW - Preload will make no difference to if an ad shows or not. You can leave preload out and an add will show but wont be preloaded and so take a second or two longer to be served.


  • Thanks for the help,

    I just tried 2 times the exact same build, one time exported to my existing folder, and it failed.

    Then using a new folder, and the ads appeared.

    Maybe I'm missing something...

    I'm using the link given in the manual here :

    Name: AdMob Plugin

    Plugin ID:

    Check the 'Plugin is located in the Apache Cordova Plugins Registry' box

    And I'm using C2 v.200

  • I use:

    Name: admob

    Plugin ID:

    Repo URL:

    Dont check the 'Plugin is located ...' checkbox.

  • Thanks, I'll try it out !

  • I tried many many things during a bunch of hours and here is what I noticed concerning the use of AdMob plugin :

    integrate a sprite object into my "main title" layout --> on touched object - Show Ad

    AdMob third party plugins data from Construct 2 Manual


    If I reexport the same game in the same XDK project with the third party plugin data you gave on the last page

    IT WORKS too

    The problem I noticed earlier was maybe because the XDK project was created with an older version of XDK. This is a new XDK project I created with the last version (1826).

    Nom here come the problems :

    In the exact same .capx file, I made a bunch of tests to see what conditions may make the ads appear. I got the following results :

    on tap gesture on Sprite + is animation playing (for the Sprite object) + check global variable --> Show Ad

    Ad never shows up (no error in my code, it should show up)

    Wait 7 seconds --> Show ad

    Ad never shows up

    Wait 7 seconds --> create object Sprite (which is not by default on this layout)

    On touched Sprite --> Show Ad

    Ad never shows up


    Every test has been made in the exact same process (test mode enabled, same C2 version (200), same XDK version (1826), same way to export, tested on the same device)

    Are there some conditions that should be used to make an add appear, while others can't??

    Any idea of what could be the problem?

    The next things I'll try is to put only the ad in a deactivated group, then activate it when a condition is met. But I am very seriously interested in knowing what conditions you use to make your ads appear.

    EDIT :

    Making a deactivated group with just

    trigger once --> show ad

    And activating the group under any condition WORKS !

    This seems to be the only reliable way to use ads as far as I know.

  • How can I download the admob plugin ?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)