Going back to Start Menu issues

  • Hey everyone!

    So I have a start menu that works just fine. When I touch xSprite it goes to the layout for selecting a level and so on.

    My issue is when I quit the level I am in and go back to the main start menu. My touch commands don't work anymore :(

    Anyone see what I am doing wrong here?

    <img src="http://imageshack.us/a/img189/6619/0010p.png" border="0" />

    and

    <img src="http://imageshack.us/a/img402/1554/0009ce.png" border="0" />

  • get this events in a new event sheet.

    Include this event sheet in both, your StartMenue and the other Layouts.

    Do this by right clicking in your event sheets and select include event sheet.

  • Also if you are restarting the layout, or going to a different layout, you shouldn't have to actually make destroy calls for all your objects. Restarting or going to a different layout should do that automatically.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Yea, I thought going to a new layout would destroy everything naturally. But, when I do go to a new layout, random buffs are set to spawn after a brick has been destroyed. So, I would go back to the main menu and have hundreds of buffs falling down lol. The destroys I added, have fixed this issue.

  • get this events in a new event sheet.

    Include this event sheet in both, your StartMenue and the other Layouts.

    Do this by right clicking in your event sheets and select include event sheet.

    I'm actually use two different event sheets already. One for the start menu and one for the "Engine" sort-a-speak, and then an additional one for unique map requirements.

  • Bump. Still cant figure out this issue.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)