When the game loads, it doesn't load all at first

  • Hi!

    I'm sorry this is a newbie question.

    When I upload my game to a server, the game loads, but it doesn't loads all at first, For example: If a song must be played at an specific time, it sounds but some minutes later. I supposed that I activated by mistake some kind of options that allows "continuous loading".

    Thanks in advance!!

    PD: Sorry for my bad english

  • Hey Akuma,

    Thats the way it is supposed to be, to avoid a long load time and get in the game quicker the sounds continue to load while the game plays (for simple games this is ok but I dont like it either).

    You might want to look up "Preloading Sounds" in the manual, with that you can force the player to wait while all the sounds are loaded before the game starts. Just note that on some older browsers this can cause your game to freeze instead of load, on Chrome though it will be fine.

  • Hey Akuma,

    Thats the way it is supposed to be, to avoid a long load time and get in the game quicker the sounds continue to load while the game plays (for simple games this is ok but I dont like it either).

    You might want to look up "Preloading Sounds" in the manual, with that you can force the player to wait while all the sounds are loaded before the game starts. Just note that on some older browsers this can cause your game to freeze instead of load, on Chrome though it will be fine.

    Wow, thank you, I didn't know that!

    Thanks a lot!

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)