Function.Param(0) is allways empty

  • Hello, iam running a function out of a group and this function doesn't get the passed parameters.

    Iam calling the function standartly like this: Function Call "MissionCompleted" (1)

    I have tryed different int, chars and it didn't help to solve the problem. I debuged it with a text plugin which is in the function. The text was >>Function.Param(0)<<. No matter what i tryed i got the 0 which means the parameter is empty.

    Any suggestions for fixing this? Thank you for trying!

  • This surely is a little error somewhere in the function call, could you show us the problem with a capx ?

    I did an example not long ago about functions, if this can help you.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Holy moly, i fixed it after hours.. I just put the text on the top of the function and it worked.

    The problem was a Wait 1.0 seconds action. When i put the output of Function.Param(0) after it, it is 0.

    Thanks for your help.

  • The wait function is dangerous. As if forces the function to wait, the events go on and the "context" isn't kept. As the Params are in the context, you don't have access to them after...

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)