How do I fix this (Solved)

  • And whatever happens I thank you very much 99instances2Go for all your help!

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I am sorry. Still an error even after all the effort.

  • It´s not the rotating beam. It´s not the birds. It´s something else.

  • tomi71

    Rather than making numerous posts one after the other, please consider editing your post instead using the 'pencil' tool.

  • tomi71

    Rather than making numerous posts one after the other, please consider editing your post instead using the 'pencil' tool.

    Well. If you read my posts, you can see that there are a numerous edits. They are made by the pencil.

    This one is not.

    edit: and this one is.

    edit2: and sorry for all my troubles. I am trying to keep it less.

    edit3: I did write too much in the few past posts. I admit it. Sorry. I will improve my ways.

  • Dont crop em in photoshop. They need the same canvas. Canvas size will be translated to the size of the imported frame.

    If it happens to you that the frames are differend in size. Then look for the biggest frame. Write the size down. Go to another frame. Click on the icon to size that frame. X & y is wut you writed down. Image = align center. Apply to whole animation. Magic happens. After that, you better set the origin for all frames the same.

    Sorry i missed that animation to fix.

  • Dont crop em in photoshop. They need the same canvas. Canvas size will be translated to the size of the imported frame.

    If it happens to you that the frames are differend in size. Then look for the biggest frame. Write the size down. Go to another frame. Click on the icon to size that frame. X & y is wut you writed down. Image = align center. Apply to whole animation. Magic happens. After that, you better set the origin for all frames the same.

    Sorry i missed that animation to fix.

    Thanks for the tip! Testing again today to see if it works today

    Edit: Testing on firefox. Has been running without error 40 minutes now.

    Edit2: No error but stopped. Firefox don´t show error supposedly. 46 minutes. I had removed the rotating beam.

    Yeah. I guess this is a rusty chunk.

    Edit3: Tested with the latest Nw.js. Worked ok for 30-40 minutes then crashed (whole program just vanished).

    I wonder if this works however since levels don´t last that long. Would be nice to find the solution for this though. I am beginning to wonder if this is a bug since in the bug section there was a game that turned unplayable after a time period. Maybe a same kind of problem than mine.

  • After all the help I still feel like I am on square one since the error remains. Learned a lot of good stuff in this topic though.

    I hope someone could help me more with this. Maybe similar things have happened and there was found a solution.

    Please help.

    edit: few thoughts. Maybe my events are not in the most perform-best order? Should I put all the "ticks" in the upperpart of event sheet?

    Must try that group thing too.

    And maybe deleting all sprites one by one until error presents itself no more. (a very slow process since error comes only after maybe 40 minutes )

    edit: The intro layout was a mess. All sprites there stacked in on top of each other etc. I put them more nicely and see if it´s a time for a champagne. Maybe I am writing this too soon, but I am optimistic and stupid.

    edit2: Still running without error. Maybe the solution was "that" simple

    edit3: error. There was still some huge overlapping sprites (fadein and fadeout). Moved them apart and see what happens. No champagne.

    edit4: No error after an hour of running. Looks promising.

    edit5: error.

    edit6: The first time I ever got this error was after I made those fadein and fadeout sprites. So I removed them. Checking out.

  • This is maybe a bug. What else could explain that it runs over an hour and then error.

    edit: Started to use a little older version which was free of errors. Going to fix those collision points in that version and start to build upon that except that one beam that somehow maybe started the problem. Tried today the older version and it run perfectly.

    So a sort of a happy end after all

    edit: after a good start there became weird problems. I just fixed once more all the collision points but the game crashes after only 10 minutes. The crash actually shuts down the computer. There are two things happening now. The game runs over an hour and then error OR it runs only 10-15 minutes and crashes totally depending on the game version.

    I wonder if the latest beta has bugs.

    edit2: Testing more. Now testing a version that ran over an hour even though it had some collision point conflicts. Now fixed them. (fixem them many times for so many versions already).

    Let´s see.

    edit: Today 7th of June. Made a new layout with nothing on it except background image and one global layer. Crashed in 35 minutes so that the computer restarts (win 7). Latest beta in C2. Now going to test the start screen in the game (uses different event sheet).

    edit: The start screen (menu) does not crash. So I think it has to be an event sheet related problem (since it crashes on different layout that uses different event sheet). I had many every tick commands and combined them and put them high on the event sheet. So let´s see if this was the problem.

    Most of my every tick commands are: System/ Every tick / set position (to another object). (I wonder if there is a better way to do this)

    I´ll let you know what happens.

  • I think it is solved. It was a performance issue. Too many ticks scattered around. Removed events that we not happening in that layout. My rotating background used ticks unnecessarily. Ticks were removed and only checked the angle of the invisible sprite which I set my background according to.

    My computer is old and lacks some performance. So that´s why I guess it worked for 99Instances2Go and not for me. I guess he has a better computer

    Thank you. Over and out.

    edit: nope. Still crashes. Even after 20 minutes. Earlier it ran over an hour.

    edit2: disabling all the tick commands to see if it has something to do with that.

    and yes it still crashed. Gonna test some game from c2 itself and see if that crashes too. This time hoping for it.

    edit3: I wonder if anybody is reading this anymore. I still need help though. No crash for c2 game (in the editor). Strange thing is that there is no error anymore. It just crashes and the whole computer crashes and restarts.

    Where is smiley for going mad, angry, desperate, sad and ... and... hopeful.

  • Okay. Nothing works for me. Now making and empty layout with an empty event sheet. If it crashes I´m going to ask about the sprite sizes. They were supposed to be divided by 2 right?

    I hope someone shows some pro interest to this problem and help not only me but everyone else that might collide himself with a similar problem.

    Bump!

  • Okay. Nothing works for me. Now making and empty layout with an empty event sheet. If it crashes I´m going to ask about the sprite sizes. They were supposed to be divided by 2 right?

    I hope someone shows some pro interest to this problem and help not only me but everyone else that might collide himself with a similar problem.

    Bump!

    Alright you need to cut it out, the people that helped you have great experience. You need to accept the fact that you need a new computer. I make games with tons on onscreen action,bullets flying left and right and no slowdown and no glitches for ANDROID , so how is it your having problems on a computer that is a much more powerful machine?????

    Solution-update computer (RESOLVED)

  • Yes. It could be it. Even though this machine has run powerful games before. This is really not helpful at all. I tried c2 game (inside it) and it didn´t crash. Just now tried an empty layout (only background sprites (not a tilemap)) without event sheet (at the same game) and it crashed. It must be something else than an old computer (it´s not that old really but few years yes. Win7 64 bit. Photoshop and many powerful software running greatly)

    I´ve played many 3D games with this without crash so... it´s still probably something else.

    I never realized that it´s a problem for someone as I am trying to explore and explain this what I am doing. Afterall it can be a hint to someone pro to realize that "it must be that" or whatnot.

    Sorry for my troubles, but this certainly is not solved.

    edit: so far there´s been only one "people" helping me not counting you of course.

    edit2: Maybe you could try one of those capx:s in here and find out if they work for you.

    edit3: Do you mean by cutting out that I can´t ask for help anymore? I think that´s strange. After all these forums are that for and solution has not yet been found. e.g I don´t know if 99Instances2Go did try the timer thing. He never answered that. Maybe he run it so that every game 100 seconds it starts over and thus the results may vary.

    edit4: I am not trying to make a fight here but find a working solution. Not trying to stomp on someone´s shoes. Not trying to do anything like that. Can´t afford to suddenly buy a new computer only to find that it still does not work

    edit5: Testing with a different computer. Telling results soon. I hope you are right and it´s about computer.

    edit6: Yesterday´s version running great on my partner´s computer (win 8.1). but can´t be sure yet. I must get it running for many hours before I turn my stubborn head.

  • So far looking good. Win 8.1 working greatly. I am soon to admit that PixelPower was right. (How to address someone by name (so that it´s in the box, I haven´t found out yet)

    I admit that PixelPower is right and it also worked in 99Instances2Go´s computer.

    So I name this incident: SOLVED.

    edit: and all this time the problem was a computer. It´s still running on my wife´s computer. I am going to run it for a week to be sure.

  • Enjoy !

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)