How do I fix this problem of mine?

  • So, I'm trying out character animations with the help of a tutorial and right now, it's not going according to plan.

    When my character drops to the platform, things start going crazy. It keeps appearing and disappearing on the screen, often appearing in two animations. Then sometimes it just teleports to another part of the map.

    To be honest, I'm practically frustrated at this point and out of ideas on how to fix it. I'd like some help please if anyone could provide any. If it helps at this point, the only behavior on for my sprite is the platform and I haven't even touched it that much.

  • Please share your project (CAPX file).

  • As dop2000 has said, without the .capx we would just be making wild guesses.

    One thing to check is ensure all origin points of the images of the sprites are the same. The same goes for the collision polygons. Both of these are accessed via the Image Editor.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • ufile.io/8bwqm

  • Have you read the comment above from zenox98??

    It's exactly the problem he described.

    You need to fix origin image points for all your sprites, all animations and all frames.

  • Have you read the comment above from zenox98??

    It's exactly the problem he described.

    You need to fix origin image points for all your sprites, all animations and all frames.

    Thanks, I'll keep that in mind for future works.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)