How do I fix this error? And how did I got it?

  • When opening a Layout I get an error window saying this:

    "Error creating OpenGL view: failed to create context

    Updating your graphics card drivers may fix this problem."

    Then I went to the Construct 2 folder and opened this "GraphicsCardUpdate.exe" file but it said the graphics card is up to date.

    I really don't know what's the problem here 0_0

  • After I click OK I get this: prntscr.com/dsmpmo

  • You can no longer rely on the GraphicsCardUpdate.exe - it's not even installed in newer builds ( removed in r237 ). Go to the GPU manufacturer's website and actual check for an update to be certain of being up to date.

    What is you system OS / GPU?

    What version of C2 are you using? You should be using at least r239.

    Is this error occurring with all .capx or just your own?

  • What is this GPU manufacturer website? Sorry if I'm asking stupid questions.

    Btw, my C2 version is r241

    This error suddenly started occuring on all .capx

  • Where did you find the GraphicsCardUpdate.exe? It doesn't even install with r241.

    Anyway, the GPU manufacturer means the website for the graphics card installed in your PC or laptop.

  • I have no clue, it probably remained in the folder from older versions...

    Actually, now I've downloaded and tried to install the latest driver update but I got this error: "This computer does not meet the minimum requirements for installing the software."

    What does this mean now? My PC cannot run C2 anymore?

    Or I'm attempting to install a wrong update?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Okay, it seems my graphics card is up-to-date but I'm still getting this error... What may the problem be?

  • What is your system? (XP, Vista, Win 7, Win 10, Linux, MAC etc)

    Is it a PC or laptop?

    If laptop, does it have more than one graphics card?

    What is the make and model of your graphics card?

    Are you using the 32 or 64 bit version of C2?

    Have you tried a total clean install? i.e. uninstall c2, delete or move the remaining folder (in case there are non-standard plugins you want to keep), reboot, download latest beta and install. Run C2 and check.

    Have you installed anything recently that may have altered your PC settings?

  • Okay, I don't know how, but I've fixed it.

    I've just clicked this "Reset dialogs" button in the settings and restarted C2 and then everything went back to normal, dunno how and why.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)