Enemy duplicate

  • Hey I have made any enemy, but when I copy and paste it, it does not perform the same functions that of the original enemy. Please could you help me out

    Thank you,

    Rafael0125

  • Are you sure you used copy and not clone?

    Which events and or functions are not working correctly?

  • shooting event is not working ... i clicked the object and copy and paste it ....

    so when the player comes close to the orignal turrent all the other turrent also starts to shoot... aafter i destroy the first turrent .. when i come close to the next turrent ( copied one) it does react it doesnt shoot ... but it does get destroyed if i shoot it ...

  • could you tell me how to get it fixed ?

  • i found out anther thing... which is very strange..

    if I shoot down the orignal turrent and destroy it ... than the other one starts to work fine ...

  • uhhhhhmmm..

    "aafter i destroy the first turrent .. when i come close to the next turrent ( copied one) it does react it doesnt shoot"

    "if I shoot down the orignal turrent and destroy it ... than the other one starts to work fine ..."

    So if you destroy the first one the rest doesn't work, but if you destroy the original the other one works fine..

    What is the difference between the first, the original, the rest and the other one?

    Because it's hard to understand what you mean..

  • so I made an Turrent, that shoots if the player is less or = than 250 units. I duplicated the turrent and placed it far away ... SO the whats happening is, if I am close to the orignal turrent, than both turrents shoot.. If i dont destroy the first turrent and jump over it and go near the 2nd turrent it wont shoot...

    But if i destroy the first turrent (orignal one) and than go to the duplicated turrent.. than the duplicated turrent will shoot if I am within the range... Or will work fine..

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I fig it out ... i used function FOR EACH .. and it works fine

    but thanks for your time ...

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)