How do I disable threaded compositing for node-webkit?

  • I strongly suspect threaded compositing is causing a random freezing bug in node-webkit.

    It has been re-enabled in ver 177, but i know there is a way to disable it, can someone please show me step-by-step how to disable it for my exported game?

  • Does random freezing still happen in r177? It would be better to fix it than revert back to disabling threaded compositing, since it effectively breaks the OS X version and I think is no longer a maintained codepath in Chrome, since the default is to have it enabled.

  • Does random freezing still happen in r177? It would be better to fix it than revert back to disabling threaded compositing, since it effectively breaks the OS X version and I think is no longer a maintained codepath in Chrome, since the default is to have it enabled.

    The freezing stopped to happen some versions ago (i guess when TC was disabled) and it's back now with 177. Searching in the forum and checking the 177 changelog i've come to the conclusion it's probably caused by the reintroduction of TC.

  • I also notice much more lag and worse performance in exported nodekit.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Does random freezing still happen in r177? It would be better to fix it than revert back to disabling threaded compositing, since it effectively breaks the OS X version and I think is no longer a maintained codepath in Chrome, since the default is to have it enabled.

    Thanks Ashley, the problem seems to be gone in v179

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)