How do I disable Sprite Font collisions ?

  • Hey all,

    I just noticed in the debug that sprite fonts and text boxes have collisions set to enabled. How do i make them disabled on startup. Unlike normal sprites there are no options for sprite fonts to turn off their collisions.

    And also 'touch' also seems to use collisions to detect if it's touching an object or not. Is there a work around for this? I have a lot on sprites on screen and touching makes the collision check count jump to very high values.

  • Good question....unfortunately I don't really know how to help...

    you could try putting a Behavior like "Solid" onto the objects and then manually disabling the Collisions On start of layout...

    I would try that to see if its a possible workaround

    but you are right,

    those objects dont seem to have a collisions checkbox, I never noticed before

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Collisions, if not verified by a behaviors (platform, solid, jump thru, etc...) or an event (on collision, is overllaping, on touched object maybe..), are not processed AT all, so you should not worry about that, as this setting make sense only when using the collisions actively.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)