How do I disable Mouse at Screen borders?

0 favourites
  • 4 posts
From the Asset Store
Total customisation of the input! You can combine inputs from all peripherals. Make your game accessible for everyone!
  • Hello.

    I have a problem with a Breakout Game compiled for Node-Webkit. If i test my Game in Construct 2 (Node-Webkit + Resolution 1920x1080 + Innerscale Fullscreen) all works great, all works perfect. But if i compile the Game with the same options, i get a problem with the Screen borders. If i move my Mouse to the Edges of the Screen, the Mouse are shown and i can not control the Player-Paddle - if i move the mouse away from the Edges, i can move the Paddle.

    I have test it with all fullscreen options, but the problem with the screen borders are resists.

    (I have disable all options for the Node Webkit when i compile the Game // Single instance - window frame - resizable window - kiosk mode)

    Here you can Download the Game for testing. Please use ALT+F4 to exit the Game!

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • What are your events for hiding the mouse? Do you have a condition that says something like "as long as the mouse *something* then move paddle"?

    i had never run into something like this before in node-webkit.

  • Joannesalfa: Thank you, the Plugin works perfect! Now the Problem is solved

    Sargas: I have use the standart Mouse Event "Set Cursor to None" to hide the Cursor (see the picture)

    And for move the Paddle i have use the Event : System Timescale ? 0 -> Paddle Set X to Mouse.X

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)