disable up as jump

  • I've been trying to disable up key as a jump button I want space key for the jump I have a couple things I try it out but they don't seem to pan out.

    I figured out how to make a character move in 8 directions with jumping but it's still the up key is what's holding me back.

    to get the player to jump with a keyboard I had to use in events page. keyboard> space is down> player box>simulate platform pressing jump.

    So then I figured to fix the up arrow problem. I should use in the event page. keyboard> up arrow is down >player box >start ignoring platform user input.

    I'm pretty sure I have to make a if or else in the event page under keyboard up arrow is down.

  • If you're using the platform behavior then you need to turn off default controls for the object. This way you can customize the controls how you want them to be. I find this best because you have a little more control.

  • Awesome that worked thanks for the help man. I can't believe I just missed a setting.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • No problem mate, happens all the time. :)

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)