Construct 2 Major Audio Bug?

  • Hi everyone, I'm not sure if this is a bug or a How do I? as it may have a simple solution. For some reason, I cannot hear any of Construct 2's audio when testing in debug or fullscreen mode, and if I watch the audio object in debug mode I can see the sounds pile up, they don't disappear when finished, and are muted. This happens on every Capx.

    I've only just found out how to even hear the game, and this involves going into debug mode only and clicking the built in Restart button. This fixes it until I try another debug, but I have no idea why, and it means I can only test the game in debug mode and after I've clicked it.

    On export of the game I can hear it, so it must be a browser issue. Changing default preview browser in preferences doesn't seem to change my browser for debug mode either.

    https://ibb.co/b8oF17

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Try installing the latest version of C2. There were recent changes on how the audio is played in Chrome and old C2 versions may no longer work.

    Set preview browser in project properties (on the left panel), not in the program preferences.

  • Try installing the latest version of C2. There were recent changes on how the audio is played in Chrome and old C2 versions may no longer work.

    Set preview browser in project properties (on the left panel), not in the program preferences.

    It's the latest version I believe, but playing it in Firefox works. Thank you!

  • The most annoying thing, now all my previous old HTML5 games (on different portals etc) have this issue

  • The most annoying thing, now all my previous old HTML5 games (on different portals etc) have this issue

    Same for me!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)