Still cant get Billing Permission?

0 favourites
  • 3 posts
  • Hey everyone

    This is my first post since downloading construct 2, there's a huge amount of information already out there and I have been able

    to find all the information I need to create my first game but I have finally run into a wall I can not pass.

    Although there is a lot of posts regarding this issue I still can not seem to get past the issue of BILLING PERMISSION on google play when using

    Cranberry IAP plugin. I have managed to get the Official IAP plugin to work correctly following the steps here on the forum, but this worked one time and then

    not again. I have seen many users successfully implement Cranberry IAP into there games so I am sure the error is on my part yet I can not seem to figure out what I am doing wrong.


    ]Below are the steps I have taken

    • Downloaded and installed the Cranberry Phonegap IAP plugin
    • Placed the Phonegap object into my game and set up relevant logic regarding its use in my game
    • Copied over the code from my google dev account labelled 'YOUR LICENCE KEY FOR THIS APPLICATION' (Base64-encoded RSA Public key to include in your binary) onto the section labelled Android licence key within my game project file (after selecting the Phonegap object)
    • Exported via Cordova out of Construct 2 (without minifying) and built using Intel XDK (the only other third party plugin being AdMob, if that's relevant at all)

    The Build is successful but when I upload the APK in place of my current APK (Alpha) Google Dev informs me that the new APK does not allow BILLING PERMISION.

    I would not post this if I had any other choice but I have been fighting with this for over a week now and this is the final piece before I can actually publish my game. So once again apologies for raising the same topic but I really need some help with this.



  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • ... p-purchase

    Scroll down to the Intel Xdk part, solved it for me!

    " Adding the “cc.fovea.plugins.inapppurchase” Cordova Plugin to your project

    Click Projects

    Expand Plugins and Permissions under Cordova Hybrid Mobile App Settings

    Expand Third-Party PluginsClick Get Plugin from the Web

    Input the Plugin’s name

    Input the Plugin’s ID (cc.fovea.plugins.inapppurchase)

    Input the Repo URL ( "

  • no it doesn't work any more !!!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)