I cannot open my project in Intel XDK

0 favourites
  • 9 posts
From the Asset Store
With this template you can create your own archer game and customize it however you want.
  • C2 exports successfully using Cordova.

    I try to open the XDK file created by C2 and Intel XDK gives me "Error opening project. TypeError: Cannot read property 'length' of undefined". It actually does load something, but it does nothing.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I have no idea how to get my exported file to work.

    Can anyone give me some guidance?

  • Construct 2 should export 2 files. One being a XDK and one being a XDKE. When you first open up Intel XDK at the bottom left there is a button that says import or open or something. Click that and browse to these files that Construct 2 exported. Then, try them both. One of them will work.

  • My project still says "Error opening project. TypeError: Cannot read property 'length' of undefined". Even when I retry with a new export from C2.

  • Which file are you trying to open? Give me the full name of the file including the extension.

  • Believe it or not, it finally worked. I changed nothing and did nothing differently and I went through without giving me an error.

    However, it is now giving me a new alert within the App View program. I ran into this same problem on a different app attempt. I posted a new thread about 2 hours ago about Cordova and XDK plugins being available.

    I see that you suggested on that post to just do a direct download to the phone. I'll have to try that. Thanks for your help. I'll let you know how it works tomorrow.

  • If you'll get this error in the future ( "Error opening project. TypeError: Cannot read property 'length' of undefined". ) just restart Intel XDK, it worked for me.

  • Hello

    keep show this error for me

    any solution for this ?!

  • I get this error, along with the long list of plugins error, several times. I am in alpha testing and trying to get rid of a couple of bugs, so i may build several times a day.

    Steps i take:

    If i get the 'undefined error' i just close XDK and re-open. I'll usually get the big error box that lists my plugins. I'll just click on any of the bottom buttons so it closes.

    Once on the project page, where you add the settings for your build, i always delete my third party plugins i have added in C2 (the only plugins i use at this time are from cranberrygame: cordovaGame, cordovaAdmob and cordovaIAP. Why? I have had several errors when building if i leave them in. So it wastes less time for me to delete them and add them again manually.

    Also, when i edit my game, layouts or event sheets, i always change the version number:,, etc.etc.

    When i do this, if i try to open that project in intel xdk, i'll get an error sometimes. So i always delete that previous project from intel xdk, which does not delete it from your hard drive, only from intel xdk's. I have to sometimes close/re-open and delete it again, but it does save some headaches.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)