Assertion Failure, Memory Warnings & Crashing

0 favourites
  • 6 posts
From the Asset Store
Memory game, with 10 levels for you to have fun. Made in Construct3, template available for purchase.
  • Hi!

    So I was happily working away on my game when suddenly I get this error message when I test the game in NWJs preview:

    I have no idea what caused this or why.

    It happened after I implemented some physics objects, but I removed them after with no difference. The error message still appears.

    If I click "OK" I can start the game up, but then when I close the window after, the NWJs is still running in the background, taking up memory and eventually gives me memory warnings and crashes the NWJs preview window.

    Do anyone know what the error message means, and what's going on? Maybe Ashley can help on this matter if its rather complicated?

    I could really use some help as this seems beyond my scope to solve.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • So you deleted all refrences to physic's objects and deleted the physic's behavior and this still shows up?

  • I didn't delete all physics objects, just the ones I created just before the problem arised, but only by removing the physics behavior from the objects, not the entire objects themselves. You reckon I should try removing the objects (sprites) as well, even in the project folder?

  • Alright, I seemed to have missed one object that I applied physics to. I removed it and now it works fine again.

    I tried to apply physics to a tilemap object, so I could implement some rolling rocks in my platformer game by adding physics to both the tilemap and the rock object.

    This seems to be causing issues.

    Is it supposed to throw errors when applying physics to tilemaps?

  • The manual states that the physics plugin is not really designed to be used with many of the other plugins.

  • Ah yes, I understand. Thanks for letting me know. I found a workaround.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)