Did anyone have vsync/tearing/stutter problems in Construct2

  • I am having some issues which have been posted here:

    Now I do not expect anyone to read such a long thread, I would like to ask briefly if anyone had problems with vsync or tearing or stutter problems in games created with Construct 2. If yes how did you overcome them?

    I am trying different options, turning on Vsync and Gsync (graphics cards = Nvidia Geforce GTX 960) and trying to limit FPS with no luck to be honest.

    I cant seem to be able to get rid of the problem.

    Ps. I have a 60Hz refresh rate monitor.

  • vsync works on my machine on firefox/chrome. If it's not disabled in your graphics card properties then i'm not sure where the issue lies.

  • Same issue here, tearing about a quarter way down from the top of the screen, like a fold.

  • Same issue here, tearing about a quarter way down from the top of the screen, like a fold.

    What graphics card have you got? Have you tried turning on Vsync? Do you have the tearing in other games too? Other 2d games?

  • Zebbi

    Ive managed to resolve the problem, read

    Perphaps it can help you as well.

  • Thanks for the suggestion, it's a Y510P laptop so it's a little different to desktop hardware, but mine is tearing on both nVidia and Intel mode of graphics (I can switch between both cards) and I've tried all the vsync options I can find.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Zebbi - what OS are you using?

    If windows 7 u need to turn on AERO for the vsync to kick in when in desktop.

  • Zebbi - what OS are you using?

    If windows 7 u need to turn on AERO for the vsync to kick in when in desktop.

    Thankyou, that seems to fix it! I set it to Windows 7 theme instead of Lenovo. Does anyone else notice v-sync always has a bit of a drag though? It should do since it has to delay the verticals to catch up, but it kinda makes the control slightly less responsive IMO.

  • Zebbi

    Glad it helped!

    What is your frame rate limit? Did you set one up? Try to set a FPS limit to 60 on your graphics card perphaps that will help with the "drag".

  • Hardware problems... the bane of software developers existence.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)