animations

  • Hello, because when spend 10 seconds all my objects move, I want you to be quiet all the time.

    If I remove all the animations of all the objects he stands me, I've tried everything and still moving...

    I leave an example for what you may see dropbox.com/s/mt92rduq2ohyy1z/test.capx

    sorry for my English <img src="smileys/smiley18.gif" border="0" align="middle" />

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Either set the collision mask to bounding box

    or update your collision polygons, because they are not straight.

    Also make sure the collision masks of your objects arent overlapping.

  • You could also avoid such problems by doing Ashley's excellent platform tutorial.

  • Polygons think are straight and keep moving ... then no solution or normal?

  • Your polygons are not straight.

    When they are straight there will be no movement.

    While editing the polygons look at the top of the image editor and select one of the points, you'll see the exact position. your polygons were at y-1.21 and y-1.35 or something like that. that isn't straight.

    So there is a solution and that is fixing your polygons.

  • to be right must be equal in x and y? must be 0, 0? an example? :(

  • no, for a line to be horizontal it has to be horizontal.

    If at one side y=1.25 and on the other end y=1.35 it is not a horizontal line.

    I've fixed your polygons, so your things don't move. Next time just make horizontal lines by inserting the coordinates into the image editor.

    updated collision polygons

  • I must be stupid, because the other items that I have do not work, that if you put me work ... I try to do the same as you and me moving ... some tutorial? <img src="smileys/smiley12.gif" border="0" align="middle" />

  • Instead of moving the colission points with the mouse enter their coordinates at the top of the image editor. Do this in the first frame of the animation, than right-click and choose use for whole animation.

  • That I do but I do not work for me ... I have a 33*32 item do the same as you and still moving ... despair of that game :(

  • It should work, because that's what I did in my updated capx.

    But maybe it would be a better idea for you to set the collision to bounding box. You can find this setting on the left in the physics settings.

    If this doesnt work as expected, maybe you should cut of the transparent pixels at the edges of your sprites.

  • Now I will try changing the collision, but to cut pinholes so I tried, but did not let me. Thanks for all :D

  • Putting collision "bounding box" do not move more. thanks <img src="smileys/smiley4.gif" border="0" align="middle" /> <img src="smileys/smiley4.gif" border="0" align="middle" />

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)