AJAX Loading – Some Characters appear as Questionmark Icon

0 favourites
  • 3 posts
From the Asset Store
Progress\Loading Bar. Now Load you game like a Professional.
  • Hi There

    I was googling and looking the forums up and down, but can't seem to find a solution for my problem.

    I'm loading a JSON file (stored in "Files") via AJAX into a Construct 2 Dictionary. Everything seems to work just fine, but some Characters such as é, à, è, ä, ö, ü do not get loaded correctly.

    Instead a diamond shaped Icon with a "?" in it appears. I've tried to set the MIME Type to "text/plain charset=utf-8" before loading the JSON and also before requesting it but it does not seem to help.

    From what i can tell the error happens while ajax is loading since AJAX.LastData already contains the wrong characters.

    System Information

    Construct 2: Release 252 (64-Bit)

    Text-Editor: Visual Stuio 2017

    Windows 10 Home: Version 10.0.16299 Build 16299

    I was hoping some of you experienced the same issue, and could direct me towards a solution.



  • Try saving the file to disk, open in Notepad, save with UTF-8 encoding, then re-import it to your project.

    This worked for me.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Nice, I've used the editor and it worked perfectly. THANK YOU! Should've asked earlier I wasted way to much time on this.


    Just realized visual studio also gives you the option to save in a specific codec just press the little arrow next to the save button. Anyway thanks again!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)