AdMob Javascript Missing

0 favourites
  • 4 posts
From the Asset Store
Game with complete Source-Code (Construct 3 / .c3p) + HTML5 Exported.
  • I know it is something simple that I am missing but I just cant seem to get AdMob ads to run.

    Any help would be appreciated.

    Here are the resources that I have used so far:

    Here are the actions that I completed, high level:

      1. In C2 add object AdmobAds
      2. In Admob site, create AdUnits, ie "ca-app-pub-#####/#####", I did notice the "/" in the ID, could that be a problem?
      3. In C2, configure AdmobAds object with applicable id's and settings Overlap = Yes; Test Mode = True or False
      4. In C2, Event sheet create the following action - System/On start of layout/AdmobAds/Show banner ad...(auto-size, recommended)
      5. In C2, click "Run Layout"
      6. In browser (Chrome or IE), there are no ads, view source and I see reference to "admob_common.js" and "admob_plugin.js", clicking these does bring up the source of the js
      7. In C2, export Export Project as HTML5 website and upload to server
      8. In browser, test code on live site and still no ads
      9. In browser, view source and no reference to .js files or admob references

    I also tried using developer mode to simulate iOS and Android with the same result. I also noticed there were no .js files for admob exported.

    I am probably missing something basic and it is making me nuts.

    The tutorial on Shatter-Box seemed to indicate that this should have worked even before exporting Cordova then importing in the Intel XDK.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Turns out that once I built the Android package in Intel XDK and installed the game on a device the ads worked.

    Still messing around with Android versions since 5.x on a phone and v? on a Kindle Fire HD both work well but 4.3 on a Galaxy S3 isnt behaving.

    I also tried with iOS using the Intel XDK emulator, the Intel XDK "App Preview" on an iPhone 6 Plus and iPad, using both the server and WiFi options, and no ads are showing. Considering using iAd instead of AdMob.

    Tempted to resort to using AdSense then doing something with a web browser control to just wrap the game since it works in browser.

    Long story short Android is working on latest OS but iOS not so much.

  • Ads will only appear in a built app. the XDK does not include XDK plugins in preview. on both Android and iOS they need to be first built using Xdk then installed to see Ads. Source-i use ad mob on my games on both

  • Thanks for the confirmation. I wont worry too much about it until I get the games are built.

    Next step, figuring out why Facebook buttons arent working. :S

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)