Adding a new function suddenly stopped working

0 favourites
  • 4 posts
  • Hi all - this is my first post here, as I recently started checking out Construct 2. It takes some getting used to, as everything new, and for some platforms HTML 5 support is not mature yet, but overall it's a very pleasant experience.

    In the first game I'm trying to make, I have added a function to control the spawning of new enemies and it worked as intended. Later on, I tried to add another function to handle pausing... but I cannot find the function object in the "Insert new object" dialog any more. It's very strange.

    Initially, I thought that it happened because had somehow messed up my installation, but if I create a new project from scratch, I can add a new function just fine.

    I also thought that it may be a limit to the Free edition, but I didn't find any such mention in the C2 versions comparison table.

    I didn't find any mention of such a problem in the forum, so, here I am, posting my first question.

    Any ideas on why this happens?



  • You only add the Function object once. Just add an event, then look for Funtion in the list.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Thanks - you are absolutely right. I thought that the function object referred to each individual function, but it's on a different level of abstraction.

    This also applies to all layouts - you add one function object and then use it to call functions from all event sheets.

    Thanks again.

  • No problem. I asked the same question once Some objects are automatically 'global', like Function.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)