XDK Emulate Not Working

0 favourites
  • 3 posts
  • I feel like I am progressing backwards with this process. I had my game working all the way to a build. I was not able to get ads working so I am stripping back the game and I am going to add plugins 1 at a time before proceeding to next step. I currently have a "pure" C2 game. Itt runs fine when I run within C2. I exported from C2 and imported into XDK. Now when I try to run in Emulate, I get a blank screen and nothing else? If I run in Test with XDK using their App Preview tool, it runs fine on my phone.

    Any thought why it would not run in Emulate? My frustration with trying to publish to mobile with C2 is reaching a breaking point so I am going to try and take it 1 step at a time. Any help would be appreciated. Thanks.

  • Emulation for me is hit and miss. Sometimes the graphics are missing when I run it the first time, until i refresh the emulation does it work sometimes. I tend not to use it any more and instead use preview mode with my phone directly.

    If you build an apk file and install this does the game work with all your plugins?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I have actually backed out the plugins because they were not working. I am in the process of trying to build it one plugin at a time. Another problem I have is the game locks in Portrait mode. If I preview and start in Landscape, it is good. If I flip phone, it switched to portrait and I cannot get it back. i have set it within C2 and within XDK.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)