xbox 360 (for pc) gamepad

0 favourites
  • 10 posts
From the Asset Store
A space themed game with high quality 2D graphics and addictive music that provide hours of fun
  • I recently bought an xbox 360 wireless controller (the "for pc" version). According to what I've read it should have the best chance of compatibility (for wireless controllers). I tried searching the forums for anyone else having this issue.

    I'm using chrome 25.0.13 and Construct 2 release 111

    The button mapping does not seem to be accurate.


    X in Construct 2 is actually A on my controller

    A is B

    B is X

    Left shoulder trigger is Back

    Right shoulder trigger is Start

    Back is Left analog button

    Start is Right analog button

    Left analog button is nothing

    Right analog is nothing


    everything else seems mapped properly

    As well as, sometimes it seems Chrome does not recognize the gamepad until i hit the a/b/x/y buttons.

    Anyone having the same issue? Or can point me in the right direction for resolving?

    Thank you,


  • The fact of pressing either a/b/x/y to activate the recognition of the pad is due to the way the gamepad API is written, it's the way of the standard, and I don't think anything can be done about it.

  • Interesting. I tried it on a different computer, just for fun. Same OS, same browser version, same gamepad, but the buttons are what they indicate, in Construct 2, on the other computer.

    I'm not sure what is happening, but I re-installed the gamepad drivers just in case. Didn't change anything for me.

    I'm sure I'm missing something, but lack of replies on this thread seem to indicate that this is not an issue for anyone else.

    A good workaround I could think of was allowing custom button mapping. Though this seems to be a pain to set up in Construct 2. And I've not found any forum posts on the subject (though the forum search results are inundated with "help test the new gamepad object" when doing any search that includes the word "gamepad".

    Anyways, ima work on the custom button mapping. I'll post my idea here after I think it through a few times.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I have a wired XBox 360 controller for testing this and it works correctly.

    Which drivers did you use? The wired controller actually has better compatibility than the wireless controller IIRC, because as soon as you plug in the wire Windows installs the correct driver automatically, whereas you have to find a driver manually for the wireless controller (correct me if I'm wrong there though).

  • I used the newest driver on both computers. My OS (win7 x64) installed built in drivers when i plugged it in the first time on both computers, but I then went through and installed the newest software package (includes drivers).

    I only seem to have problems with the button being off on the one computer, but I built a custom button mapping process into my game so it works no matter what (once I map the buttons of course).

    Support Page:


  • You can work with it for now ...

    I'm sure the devs will find a solution soon enough

  • Speaking of custom button mapping....

    I don't have a stripped down capx, sorry, but I'll try to explain what I did.

    I made a button that shows up when I hit the esc key. This button can then be clicked to start the "button mapping" process.

    An on screen prompt will tell you what to do.

    Push (A) button,

    Push (B) button,

    Push (X) button,

    and so on...

    Using the "any button pressed" gamepad event and the "last button" expression I record the button that is pressed and store it's code in a variable for each button.

    variable: buttonA

    variable: buttonB

    variable: buttonX

    and so on...

    this way you can always use the variable for the button you want and it will use the corresponding "mapped" button code.

    and to go one further with it...

    I then have it go through the actions to map buttons to.

    "Please press the button to map for Jump"

    "Please press the button to map for Run"

    "Please press the button to map for Shoot"

    and so on...

    I had to build in a check for each action mapped, so that if you hit a button that has already been mapped to an action it will clear the previous button.

    So the first part maps my buttons correctly, and the second part maps the actions to the buttons I want.

    again, to go further...

    I also set up other buttons on a menu that allow me to see what button is mapped for what action, as well as clickable buttons in the menu that let me map each action individually.

    So each clickable button just calls the one specific event related to mapping that action.

    This was all incredibly time consuming, but it's really helped me through development (cause I can change what my buttons do instantly), and I think it will be best in the long run for the end user/player, so you know that everyone will be able to play it (as long as their button presses are recognized by chrome anyways)

    in the future...

    Eventually I will flesh it out to be more polished. I'd like to include it as part of the options menu, and then also separate the mapping from the assigning of actions to buttons.

    If I can figure some way to strip down a copy of my capx without having to redo the whole thing I'll post it here for reference. I don't have all the buttons in variables, etc, but enough to get the idea.

  • You can work with it for now ...

    I'm sure the devs will find a solution soon enough

    I hope I'm not coming off as though I'm looking for someone to "fix" this, I'm only trying to figure out if my experience is abnormal, which it seems to be.

    I'm also hoping that if there are others with similar/same issues, they'll be able to learn from what I've been through.

  • Oh and don't forget to post it in the bug section , I have no Xbox controller , which is sad , so I can't help you !


    Sad news !

    Oh well , Nevermind !

  • Oh and don't forget to post it in the bug section

    I guess that's what I'm trying to say, I don't think it's a bug.

    Thank you for your input though, It's always nice to get a fresh thought process on an issue.


Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)