WebGL performance plunge!

  • So I just did a malware scan, and after restarting the computer WebGL performance across the board, from node-webkit to chrome to firefox, has decided to take a nose-dive from 50-60 fps to what looks like herky-jerky 15-20 fps. Graphics driver re-install doesn't help and re-installing C2 doesn't help either. All other non-webgl 3D apps run as fast as they ever did. What on earth could be causing this? Is there a way to clean out and re-install all webgl-related drivers and whatnot completely?

  • What does chrome://gpu say?

  • Here it is:

    https://dl.dropboxusercontent.com/u/70562654/gpu.htm

    I notice that Chrome refers to the integrated chip which has drivers from waay back. Not much I can do to update that one, it's an "old" laptop with custom Optimus drivers from the manufacturer. But the performance slog seems just as bad for the Geforce GT 540M card.

    EDIT: Hm. It doesn't actually work to try to force Chrome to utilize the Geforce card through Nvidia settings. Chrome://gpu shows It just falls back to integrated. Maybe that's what's happening with node-webkit as well?

  • I think you can force chrome to use your gpu if you enable "ignore-gpu-blacklist' in chrome://flags .

    not sure if this would help in your case but may be worth trying.

  • The Intel Graphics driver is from 2010, which probably means it's been blacklisted. In dual GPU systems you need to update the driver for both GPUs, so you have two drivers. Try heading to Intel's site and installing the latest Intel graphics driver from there as well as the latest nVidia one.

  • Unfortunately that won't work I think. I've tried to install generic intel integrated drivers separately before and that bombed the whole gpu switch system. Can't just disable it either, grrr.

    But if the gpu was blacklisted, wouldn't rendering fall back to Canvas2D then? I have several shader effects going and if they got disabled I'd see it right away.

    I'll try to make a system restore point and install the intel drivers separately again. See what happens. Thanks for the suggestions, both

  • Unfortunately that won't work I think. I've tried to install generic intel integrated drivers separately before and that bombed the whole gpu switch system. Can't just disable it either, grrr.

    But if the gpu was blacklisted, wouldn't rendering fall back to Canvas2D then? I have several shader effects going and if they got disabled I'd see it right away.

    I'll try to make a system restore point and install the intel drivers separately again. See what happens. Thanks for the suggestions, both

    If blacklisted, the rendering would I think fall back to a software rendered webGL in chrome, not 100 percent sure though.

  • Did is find Any? if so You should try reinstalling/ repairing your browsers most malware/ virus's can infect and break alot of browser features

    If it didn't what software did you scan with? Some will install browser plugins and they all have bad performance impact.

    I would also make sure it's not still scanning or anything because malware scanners also take up alot of cpu and memory use

    Just advise from an IT person

  • Found the problem!

    The individual program settings for optimus got borked somehow, so C2 / WebGL exes had started using the integrated card exclusively. It's fixed now and everything is nice and smooth again, phew...

    [quote:1j3dyjui]Did is find Any? if so You should try reinstalling/ repairing your browsers most malware/ virus's can infect and break alot of browser features

    If it didn't what software did you scan with? Some will install browser plugins and they all have bad performance impact.

    I would also make sure it's not still scanning or anything because malware scanners also take up alot of cpu and memory use

    Thanks for the tip

  • There still should be newer Intel drivers available unless it's really old hardware... you should just need to go to their driver auto-detect page and it'll give you the right one, I don't think "generic drivers" exist for graphics hardware so probably means you got the wrong driver...

    In Chrome and the latest IE11, we use a special flag to avoid software-rendered WebGL mode, so that shouldn't happen any more.

  • The auto-detect page complained about custom drivers from the manufacturer but installing manually worked out. No real difference performance-wise on the intel side, but it's good to have fresh drivers in any case. Thanks for the pointer

  • I may do the same thing. Just recently the shooter demo that uses WebGL effects suddenly starting playing at a poor frame rate. I don't use WebGL effects much in the first place, but if I do start, I'll definitely need to look into it. :p

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • So ErekT fixed his problems... CHROME webgl using integrated card exclusively...

    I've just installed the physx component, along with the 3d element - driver version 347.09

    (i have a 3d-samsung... not sure if I'll ever use 3d, but anyway) I don't install the NVIDIA HD Audio / User Experience

    Like erekt, my chrome browser reports intel...

    Is there a setting you can use?

    I'm on windows 7 ultimate (64-bit). running chrome portable v39.0.2171.95 (64-bit), problem also exhibited with native chrome...

    thanks in advance for any helpful suggestions...

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)