TiledBackground border

  • Hi, usually i don't make use of TiedBackground for level design, so is normal that the border of TB appear during runtime?

    Tks

    <img src="http://dl.dropbox.com/u/46383802/report/tile.png" border="0" />

  • I have this issue too, so if anyone can give an explanation on this it'd be much appreciated!

  • Ashley@

    Try enabling 'Pixel rounding' in project properties. It was designed to help solve this issue. It will stop any rendering happening between pixels, which is when seams can appear.

    Post

  • That looks like a glitch, can you share a .capx demonstrating the issue?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Ashley:

    I can't speak for cesisco, but in my case Pixel Rounding doesn't make any difference.

    I suspect it's an issue with the graphics card, or something similar, as opposed to something related to a specific capx. My Monkey on a Unicycle game in the arcade, for example, shows seams on my computer clearly, regardless of whether I'm using Chrome, Firefox, or IE:

    <img src="http://imageshack.us/a/img803/3518/moauseams.png" border="0" />

    Not only that, but it blurs things significantly.

    Trying this on another computer gives different results, with a sharper image and no seams.

  • That looks like a glitch, can you share a .capx demonstrating the issue?

    Ashley, for me this only happens when Sampling setting is "Linear" and zooming events(or scrollTo behaviour).With sampling setting to "point" the tiled Backgrounds works fine.

    Here's a capx with an example(this is an example Sqidster posted for zoom in and zoom out last week...and i stole) <img src="smileys/smiley2.gif" border="0" align="middle">

    tiled_test

  • This is actually by design.

    The Tiled Background object supports seamless tiling even at sub-pixel positioning, so you never see "seams" even when scrolling smoothly. However, this means images like your example still "wrap" around to the bottom at the very top of the image. So it's actually displaying the bottom row of pixels of the texture image for about half a pixel along the top of the image (and the same thing happens at the bottom, but you probably don't notice it).

    I can't think of any way this can automatically be fixed - it's just how tiled rendering works on a GPU. The best workaround is to add a row of transparent pixels at the bottom of the image.

  • So the tiled background is essentially scrolled half a pixel down then? That's a pain...

    Thanks for the answer.

  • I use tiled background a lot, only fix I could find was to invert the images X position and adjusting manually, it's not perfect but it works for most background cases.

  • I had the same issue. I resolved it by ensuring my tiled background was power of 2 and also but adding a transparent section at the top and bottom.

  • Ok Ashley, thanks!, i'll try the transparent section solution.

  • Old thread is old, but I updated my graphics drivers and this issue was gone. So just in case anyone searches this issue up later, make sure your graphics card drivers are completely up-to-date.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)