Tile map window not rendering correctly?

  • I`ve just started to use tilemaps for the first time and seem to have an issue with the tilemap editor not working as expected.

    When I click tiles for selection they are not highlighted in any way, in fact the only thing updated is my cursor position, there are no other visual clues as to what I am selecting.

    I have watched several videos of the tilemap editor in action which shows the currently selected tile highlighted. Also, when multiple tiles are selected they are all highlighted in the editor window. I am not getting this at all so it makes it hard to see what I currently have selected.

    Am I missing something obvious here? Has anybody else experienced this issue?

    Any help would be most welcome.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Without actually having a look at it, or not having C2 open right now, I know there are a few icons above the tilemap view and there may be one if selected you do not see the highlight. Make sure you have the pencil (i think that is the icon) selected which is the mode you want to draw the tiles. Just a guess. If that doesn't work, get a screenshot and post it

  • Thank you for the reply but no luck I`m afraid.

    I have tried each tool and they all work as they should but the actual tile part of the editor itself has no overlay at all, just the tiles themselves.

  • Same issue here. I just figured they don't highlight. But if they're suppose to, then I'm not sure why they aren't for me.

  • Have you tried changing your theme to see if it highlights on the other ones? (You change it in the preferences in C2)

    Yea from opening mine, my tiles are highlighted with a translucent blue when selected. If changing your theme doesn't work you might wanna post a bug and show some screenshots.

  • I`ll try changing the theme and then update with my findings...

    Edit : OK, I have tried changing my theme around but still the issue persists. If I cannot find a solution today I will post it as a bug.

  • Prominent, can I ask which OS you are using?

  • Windows vista..

    I also am using the windows vista basic color theme. Not the aero theme, because aero would cause the family window to become invisible for some unknown reason.

  • Thanks for the reply. I`m on Vista too so maybe that could be the problem. Strangely, I am using the aero theme with no family window problems.

  • Yea, I didn't have any problems with the family window in the past, but it decided to stop working one day. I even tried reinstalling c2, but still have the problem unless I use the basic theme.

    Anyways- yea, maybe it's something related with Vista.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)