Would it be possible to allow to create a generic names for functions based on constants?
At the moment the situation is like below:
And it's understandable. But since in C2 functions are always global it would be nice to allow to make a kind of generic function names for code which could be easily reusable.
For instance I use my "pushWall" module in several places which has a generic callback depends on the currently processed action. I know I can use a static callback and pass parameter to detect action but that forces me to create a dedicated place for handling all callbacks, which brings mess to the code as I want to keep everything encapsulated as much as possible.
So basically it's all about removing the restriction (obviously only for constants) visible on the screen above. Would you consider this change?